Announcement

Collapse
No announcement yet.

ERROR: GetBuildPlatform: No BuildPlatform found for Android

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ERROR: GetBuildPlatform: No BuildPlatform found for Android

    I am using UE 4.23.1 on Mac OS 10.14.6 trying to program my oculus go. I have followed the instructions here: https://developer.oculus.com/documen...tart-guide-go/ but have a few issues.

    First of all, on step 13, there is no option for "Configure the AndroidManifest for deployment to Oculus Mobile". I did see a dropdown for "Package for Oculus Mobile Devices" and I selected "Oculus Go/ Gear VR" from it.

    Second, even though the oculus is definitely plugged in and in developer mode, I can't see it in the dropdown menu for Launch. If I open the project launcher I see it, but when I try to run my project on it I get the error: "ERROR: GetBuildPlatform: No BuildPlatform found for Android".

    Does anyone have any idea why this would happen? I have seen this issue online in other posts, but none of them answered the question adequately.

    #2
    I am running into the exact problems.
    I followed every step here https://developer.oculus.com/documen...t-guide-quest/
    After I clicked Launch -> Quest on my unreal editor, the shaders compile and then after all of them were compiled the launch fails.

    Attached is my error log.

    @devs please advise !
    Attached Files

    Comment


      #3
      I found another thread that went into a little more detail and pointed me in the direction of checking my NDK path. I ended up switching the path to an NDK installation that was part of a Unity install which led to more informative error messages. This resulted in my downloading ndk r14b and that seemed to fix something but it seemed my Java sdk path wasn't set up correctly either. This is where things got fuzzy (it was late at night). Something I read caused me to think I needed to add some environment variables so I opened up the Environment Variables control panel and found the "JAVA_HOME" variable already set to "NVPACK\JDK.1.8.0.77" so I just copied that path into the Unreal project settings and from that point I've been able to build to android. I'm in UE4 4.24 on Win10 and I've been following tutorials from the Oculus Website to deploy onto Oculus Quest. I hope this helps!

      Edit: I just learned that the codeworks installer sets the environment variables for you and that leaving the android sdk paths blank in the project settings falls back to those environment variables. A much easier solution!
      Last edited by shimster13; 02-23-2020, 12:55 PM. Reason: Found a simpler solution

      Comment

      Working...
      X