Announcement

Collapse
No announcement yet.

Oculus Quest strange green artifacts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Oculus Quest strange green artifacts

    Oculus quest strange things.
    UE 4.23 p7
    I follow the instructions in this video: https://youtu.be/hEtu-ciPc7g I was able to successfully install the standard VR template on Oculus Quest, all the mechanics (tracking of the head and hands, buttons on the controller, and so on, work successfully), but there is one strange thing: when the application is launched for the first time, immediately after creating lunch through the menu, everything looks great.
    but after closing, disconnecting from the computer and reopening, some objects and hands become covered with green highlights.
    What am I missing?
    Click image for larger version

Name:	7DC4FBEFD41140F3AA4ACB819AE995E1.jpeg
Views:	108
Size:	84.9 KB
ID:	1656978

    #2
    I would use the Oculus Branch found on their github if you're developing specifically for Quest.

    Comment


      #3
      I have this too. It appears to be random even time I start my packaged project. My first thought was that the reflection texture is corrupt. So I tried to remove the skylight in my level and it seems have fixed the problems. But like I said, it's happens random so it might be still be there but I'm lucky it doesn't show up.
      Working at the University of Groningen
      UE4 on a huge display
      UE4 VRPN plugin

      Comment


        #4
        TRY THIS: under the android build settings, disable OpenGL es2 and es3 and select vulkan. That should fix it.

        Comment


          #5
          The VR template has some unique .ini settings -

          Try changing "r.Mobile.UseHWsRGBEncoding=True" to False in DefaultEngine.ini

          Comment


            #6
            Originally posted by Alex O View Post
            The VR template has some unique .ini settings -

            Try changing "r.Mobile.UseHWsRGBEncoding=True" to False in DefaultEngine.ini
            Hi Alex,

            This automatically gets changed​​​​​​​, so something may be overriding it. Could it be a shader/texture property forcing it to =True ?

            Comment


              #7
              did anyone found a solution to this?

              Comment


                #8
                Hey all, I got a bug submission in for this, so I took a look at it in 4.24 preview 1. ( Scalable quality, Mobile/Tablet , XR Enabled)

                I had to disable Instanced Stereo in DefaultEngine.ini (known issue (fixed in preview 2) that will cause project to crash when opening)

                But after disabling that and adding 'Quest' to that array, I was able to launch onto the Quest with none of those artifacts.

                Comment

                Working...
                X