Announcement

Collapse
No announcement yet.

Issues getting Unreal project run on the Quest

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [OCULUS] Issues getting Unreal project run on the Quest

    Hello everyone,
    First of all, sorry if my english isn't so good. I hope its good enough to understand my problem

    I try to develop an application for the Oculus Quest.
    Everything is configured with tutorials and the Quest is in Developer mode.

    I've startet a Project with the VR Template and made all the settings with an Tutorial.
    For testing i just used the standart "MotionControllerMap" and packed the Project for Android (All).

    After the packaging was finished i've sideloaded the apk with Sidequest,
    The installation works and i can find my app in the library of my Quest.

    But the Problem is, if i try to start the app, The screen gets black for a second and the app closes immediately without any message.

    I think, i've used every Tutorial in the internet and getting a bit frustrated, cause it seems like i'm the only one with this problem :/

    It has to be an UE Issue, cause, other Apps I've sideloaded work perfectly.

    I hope, i described the problem understandable, and someone here can help me, setting up my project correct.

    #2
    Hello Bantol,

    I have exactly the same issue.

    The only solution I found that works most of the time is to reboot the Quest and launch the app from the unknown source menu.



    Here is a little python script that I run after Unreal has finished the build :

    https://gist.github.com/ivanjames69/...17ea0a08cd5dd1



    If anyone has a REAL solution I'm interested !

    Comment


      #3
      Try the action in this video from the link below to get a quick start. Use the launcher standard version 4.23 for beginning it works fine if you follow all step in the video.

      https://www.youtube.com/watch?v=jlcj4HB9LX8

      Comment


        #4
        Same problem here, Running XXXXX on quest, but it close with no mesage, it was working fine last 2 days but sudently this happens

        Comment


          #5
          Originally posted by Shikako137 View Post
          Same problem here, Running XXXXX on quest, but it close with no mesage, it was working fine last 2 days but sudently this happens
          And if you reboot your Quest and launch the app manually does it work ?

          Comment


            #6
            I resolved this by using the oculus branch (4.22.2 in my case) of ue4. Works fine so far. I only encountered problems with the launcher version on go and quest.

            Comment


              #7
              Originally posted by Ivanjames View Post

              And if you reboot your Quest and launch the app manually does it work ?
              No bro,the other maps on my app runs fine but not this evil one.

              If i reboot and open manually, the app runs fine until it arrives to this map. Turns black and go back to oculus home.

              I passed the map to a partner and he can run fine in his oculus. It blows my mind.

              Comment


                #8
                Originally posted by jinzay View Post
                I resolved this by using the oculus branch (4.22.2 in my case) of ue4. Works fine so far. I only encountered problems with the launcher version on go and quest.
                On my part I'm having the same issue with the Oculus branch 4.22.2 (game is crashing after build, works only after reboot of Quest, sometimes after two reboots).


                Originally posted by Shikako137 View Post
                I passed the map to a partner and he can run fine in his oculus. It blows my mind.
                I can try it on my Quest too if you want, maybe there's some defective Quests.

                Comment


                  #9
                  I was having this problem found out you have to turn on "configure the androidmanifest for deployment to oculus mobile" under Advanced APK Packaging.
                  Devin Johnston
                  Senior Associate
                  Kirksey | Architecture

                  Comment


                    #10
                    Originally posted by Maxer View Post
                    I was having this problem found out you have to turn on "configure the androidmanifest for deployment to oculus mobile" under Advanced APK Packaging.
                    if there is no it
                    what should I make guys?

                    Comment


                      #11
                      They've changed it from version 4.23 - you need to expand the 'Package for Oculus Mobile Devices' section and specify the Quest in the drop-down menu,

                      Comment


                        #12
                        Originally posted by Bantol View Post
                        Hello everyone,
                        First of all, sorry if my english isn't so good. I hope its good enough to understand my problem

                        I try to develop an application for the Oculus Quest.
                        Everything is configured with tutorials and the Quest is in Developer mode.

                        I've startet a Project with the VR Template and made all the settings with an Tutorial.
                        For testing i just used the standart "MotionControllerMap" and packed the Project for Android (All).

                        After the packaging was finished i've sideloaded the apk with Sidequest,
                        The installation works and i can find my app in the library of my Quest.

                        But the Problem is, if i try to start the app, The screen gets black for a second and the app closes immediately without any message.

                        I think, i've used every Tutorial in the internet and getting a bit frustrated, cause it seems like i'm the only one with this problem :/

                        It has to be an UE Issue, cause, other Apps I've sideloaded work perfectly.

                        I hope, i described the problem understandable, and someone here can help me, setting up my project correct.
                        dear bantol have you solve the problem ?.. i am facing exactly the same problem .. and just stuck..

                        Comment


                          #13
                          Yes, i have the same and i can't fix that.. Just closed on opening in Quest

                          Comment


                            #14
                            Originally posted by Ferox View Post
                            Yes, i have the same and i can't fix that.. Just closed on opening in Quest
                            same issue here, 4.25. No idea what's going wrong or how to fix it.

                            Comment


                              #15
                              Not sure if this was solved for you, but I ran into this issue. Make sure you actually specify the NDK version [android-19] rather than [latest].

                              Comment

                              Working...
                              X