Announcement

Collapse
No announcement yet.

"Shimmering" with HP Reverb

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Shimmering" with HP Reverb

    I hope I'm using the correct term here, but we are seeing a lot of shimmering with the HP Reverb in Unreal.

    We're using the WMR plugin, forward rendering and MSAA.

    To describe what we are seeing with different words, many edges of objects "glitter" and appear to have micro movements, like crawling ants.

    #2
    I don't have an HP Reverb, but I've done some work with the HTC Vive and Oculus Rift. I think what you're talking about is the shimmering that is caused by the aliasing on highlights on edges. These usually appear in edges that are very shiny or have very thin quads. If MSAA is not enough to fix the issue, I think you can try increasing the roughness of the material on the object to prevent the highlights from appearing.
    Gabriel Enriquez
    Blueprints, C++, VR, AR Developer | 3D Environment Artist

    My Portfolio: ArtStation
    Profile Links: Facebook | Twitter | Instagram | LinkedIn | Steam

    Comment


      #3
      The proper way of fixing aliasing caused by specular highlights is using Unreal's built-in curvature to roughness filter on your roughness textures. Open up your roughness texture (or mask texture which includes the roughness), scroll down in the details panel to compositing, add your normal texture there, and set up the properties in the dropdown underneath it as required.

      Comment


        #4
        Thanks for the tips!

        We discovered that if you crank the MSAA console setting up to 8, the shimmering goes away, but then the framerate also drops to single digits...

        Comment


          #5
          Originally posted by Lhorkan View Post
          The proper way of fixing aliasing caused by specular highlights is using Unreal's built-in curvature to roughness filter on your roughness textures. Open up your roughness texture (or mask texture which includes the roughness), scroll down in the details panel to compositing, add your normal texture there, and set up the properties in the dropdown underneath it as required.
          We're actually seeing more shimmering on the edges of the models, not from the textures.

          And... I do think that I'm personally beginning to prefer deferred with TAA over forward with MSAA on the Reverb... there's no shimmer then and the resolution is good enough that it's not really blurry anymore (plus, I can use the otherwise rather poor AO that Unreal provides).

          Comment


            #6
            Originally posted by TheGabmeister View Post
            I don't have an HP Reverb, but I've done some work with the HTC Vive and Oculus Rift. I think what you're talking about is the shimmering that is caused by the aliasing on highlights on edges. These usually appear in edges that are very shiny or have very thin quads. If MSAA is not enough to fix the issue, I think you can try increasing the roughness of the material on the object to prevent the highlights from appearing.
            Since you also mention highlights, you can actually basically see what I'm talking about just in the VR preview on the desktop, because the shimmering from the scaled down preview is much like what you see in the headset (and this is while shaders were recalculating for forward, so there's just the checkerboard material on everything):



            I believe it's the micro head movements that you constantly do that makes the problem way, way worse than if you use a smoothly controlled camera as in traditional desktop 3D applications.

            Comment

            Working...
            X