Announcement

Collapse
No announcement yet.

The Livelink connection in the FaceAR sample project is not linking?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    The Livelink connection in the FaceAR sample project is not linking?

    We have followed the instructions for setting up the FaceAR Sample project (https://www.youtube.com/watch?v=AIHoDo7Y4_g) and have everything running.

    However the Livelink does not seem to be activated: the Windows 10 app does not show any updates the iOS app should be sending out.
    iOS does detect the face and updates within the app.

    -> Both machines are on the same network and should be able to see each other. (Check with a small setup using OSC communication)
    -> Tried this in 4.20.3 and 4.22.1
    Do we need to add any special rules to the (Windows default) firewall?

    In the docs (https://docs.unrealengine.com/en-US/...ple/index.html) it says:
    "Launch your Project, and in Project Settings set Supports AR to On."
    Searched back and forth but I cannot find this setting in the project settings, can this be the cause?

    Thanks in advance for any tips which will push us in the right direction towards a working setup.

    (cross posted here https://forums.unrealengine.com/unre...67#post1630367 as I didn't know where to place this)

    #2
    For those ending up in this subject: one thing we found out: when the iOS app is build in 4.22, the Windows side also need to be running 4.22. A project running in 4.20 will not (properly?) receive any Live link input.

    Comment


      #3
      If you go on settings in the FaceAR app on the iPhone and choose the LiveLink connection, then with the correct ip-address, tap connect.

      So, every time it doesn't connect just tap connect again on the phone. I have to do it all the time.

      Comment

      Working...
      X