Announcement

Collapse
No announcement yet.

AR "Add Runtime Candidate Image" won't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    AR "Add Runtime Candidate Image" won't work

    I have been trying to add an image to a SessionConfig Candidate Images list using the Add Runtime Image Candidate node in the editor and packaging for Android and I haven't been able to make it work in 4.22.1, 4.21.1 or ARCore's branch of 4.21.
    I have tried different ways of referencing the SessionConfig, using JPEGs and PNGs in color and in grayscale and no matter what I do the node always returns null.
    Do I need something special to make it work? Can anyone replicate?

    #2
    Hi, I've got the same issue. Working with ARCore modified 4.21 engine.
    Did you find a solution yet?

    Comment


      #3
      I have the same issue

      Comment


        #4
        Same isssue here, can anyone help?

        Comment


          #5
          Hi,

          how are you using jpes or pngs?
          Are you converting to a Texture 2D and then ARCandidate Image at runtime?

          For example in BPs:
          "Import File as Texture 2D" -> "Add Runtime Candidate Image" -> Add Candidate Image

          Comment


            #6
            Originally posted by CosmicLobster View Post
            Hi,

            how are you using jpes or pngs?
            Are you converting to a Texture 2D and then ARCandidate Image at runtime?

            For example in BPs:
            "Import File as Texture 2D" -> "Add Runtime Candidate Image" -> Add Candidate Image
            Yes, that is exactly my setup.
            "Import File as Texture 2D" - return value into "Add Runtime Candidate Image".

            I could see the image after importing, converting it to a brush and making it an image widget.

            Haven't tried to see if it's fixed in 4.23 or 4.24p yet.

            Comment

            Working...
            X