Announcement

Collapse
No announcement yet.

Cannot package UE4 project: "ovr_PopMessage already defined"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [OCULUS] Cannot package UE4 project: "ovr_PopMessage already defined"

    I'm trying to package a project in UE4, and it's throwing the following error during the build process:

    UE4-OnlineSubsystemOculus-Win64-Shipping.lib(Module.OnlineSubsystemOculus.cpp.obj) : error LNK2005: ovr_PopMessage already defined in LibOVRPlatform64_1.lib(LibOVRPlatform64_1.dll)

    Everything works fine in the editor, it just won't package.

    Why is there a conflict between OnlineSubsystemOculus and LibOVRPlatform...? Aren't these both Oculus libraries?

    I have tried doing totally clean rebuilds of the project and the issue persists.

    Anyone know what's going on here?
Working...
X