Announcement

Collapse
No announcement yet.

How to ensure audio defaults to Oculus Rift?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [OCULUS] How to ensure audio defaults to Oculus Rift?

    I'm beta testing a VR experience at the moment, and some people are reporting that the audio is not defaulting to coming out of their HMD (Oculus Rift).

    In my Project Settings, I have Platforms -> Windows -> Audio -> Audio Device set to Headphones (Rift Audio). I thought that would take care of it, but apparently not.

    What do I need to do to ensure that the audio always come through the HMD?

    Thanks!

    #2
    Originally posted by localstarlight View Post
    I'm beta testing a VR experience at the moment, and some people are reporting that the audio is not defaulting to coming out of their HMD (Oculus Rift).

    In my Project Settings, I have Platforms -> Windows -> Audio -> Audio Device set to Headphones (Rift Audio). I thought that would take care of it, but apparently not.

    What do I need to do to ensure that the audio always come through the HMD?

    Thanks!
    This section of the Oculus Rift development site explains what you need to know on the topic: https://developer.oculus.com/documen...s/dg-vr-audio/
    CTO | Head of VR Development - Visit us at http://humanxr.com
    My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

    Comment


      #3
      Interesting... that page seems to suggest you don't need to do anything:


      "When Unreal PC applications are launched, if the OculusRift plugin is enabled and the Oculus VR Runtime Service is installed, then the application will automatically override the default Windows graphics and audio devices and target the Rift. The Oculus VR Runtime Service is installed with the Oculus app."

      So maybe I'm throwing things off by making that selection in the Project Settings at all? The other options in the drop down menu for that setting are Realtek Digital Output and Realtek Digital Output (Optical) so perhaps those are settings specific to my computer...

      Comment

      Working...
      X