Announcement

Collapse
No announcement yet.

ARcore development HelloARUnreal 4.20

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    ARcore development HelloARUnreal 4.20

    Hi,
    after some difficult time setting up the environment so I can try the Hello World ARcore I am unable to run it. Skipping all the tedious task and monstrous size of the 60+ gigs repository to build UE4-20 with arcore sdk 1.5. Went "almost" as it was in Quickstart guide (took me about 10 hours but ok).

    After all this the Project Packaging as for Android -> ASTC as suggested I am encountering this issue:

    Code:
    UATHelper: Packaging (Android (ASTC)):   Building 1 action with 4 processes...
    UATHelper: Packaging (Android (ASTC)):     [1/1] HelloARUnreal-armv7-es2.so
    UATHelper: Packaging (Android (ASTC)):     D:\Unreal\UnrealEngine\Engine\Plugins\Runtime\GoogleARCore\Source\GoogleARCoreBase\Private/GoogleARCoreAPI.cpp:307: error: undefined reference to 'ArConfig_setFocusMode'
    UATHelper: Packaging (Android (ASTC)):     D:\Unreal\UnrealEngine\Engine\Plugins\Runtime\GoogleARCore\Source\GoogleARCoreBase\Private/GoogleARCoreAPI.cpp:344: error: undefined reference to 'ArCameraConfigList_create'
    UATHelper: Packaging (Android (ASTC)):     D:\Unreal\UnrealEngine\Engine\Plugins\Runtime\GoogleARCore\Source\GoogleARCoreBase\Private/GoogleARCoreAPI.cpp:346: error: undefined reference to 'ArSession_getSupportedCameraConfigs
    ...
    UATHelper: Packaging (Android (ASTC)):     clang++.exe: error: linker command failed with exit code 1 (use -v to see invocation)
    UATHelper: Packaging (Android (ASTC)):   ERROR: UBT ERROR: Failed to produce item: D:\Unreal\arcore-unreal-sdk\HelloARUnreal 4.20 - 2\Binaries\Android\HelloARUnreal-armv7-es2.so
    UATHelper: Packaging (Android (ASTC)):          (see D:\Unreal\UnrealEngine\Engine\Programs\AutomationTool\Saved\Logs\UBT-HelloARUnreal-Android-Development_2.txt for full exception trace)
    UATHelper: Packaging (Android (ASTC)):   Total build time: 45,22 seconds (Parallel executor: 0,00 seconds)
    UATHelper: Packaging (Android (ASTC)): Took 45,4390473s to run UnrealBuildTool.exe, ExitCode=5
    UATHelper: Packaging (Android (ASTC)): ERROR: UnrealBuildTool failed. See log for more details. (D:\Unreal\UnrealEngine\Engine\Programs\AutomationTool\Saved\Logs\UBT-HelloARUnreal-Android-Development_2.txt)
    UATHelper: Packaging (Android (ASTC)):        (see D:\Unreal\UnrealEngine\Engine\Programs\AutomationTool\Saved\Logs\Log.txt for full exception trace)
    UATHelper: Packaging (Android (ASTC)): AutomationTool exiting with ExitCode=5 (5)
    UATHelper: Packaging (Android (ASTC)): BUILD FAILED
    I have cloned the arcore-unreal-sdk with the examples and imported the HelloARUnreal 4.20 which made a copy from which I am trying to build up the HelloARUnreal.

    Any tips on what went wrong?

    #2
    What device are you deploying to?

    Comment

    Working...
    X