Announcement

Collapse
No announcement yet.

VR Splash Screen crash deploy

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VR Splash Screen crash deploy

    Hello. I'm trying to insert a splash screen before starting the levels of my project. I inserted the blocks in the primary blueprint level, the image was compressed in UserInterface2D (RGBA). When I play in the editor everything is fine but when I play the deploy project works the first time and then crashes the following times. I tried various formats and different images but I have the same results.
    UE4 4.20.3
    SteamVR last upgrade

    Assertion failed: !SteamVRHMD->VRCompositor [File:\Build\++UE4\Sync\Engine\Plugins\Runtime\Steam\SteamVR\Source\SteamVR\Private\SteamVRSplash.cpp] [Line: 52]

    !FDebug::AssertFailed()
    !FSteamSplashTicker::Tick()
    !TickHighFrequencyTickables()
    !TickRenderingTickables()
    !TGraphTask<`FRenderingThreadTickHeartbeat::Run'::`7'::EURCMacro_HeartbeatTickTickables>::ExecuteTask()
    !FNamedTaskThread::ProcessTasksNamedThread()
    !FNamedTaskThread::ProcessTasksUntilQuit()
    !RenderingThreadMain()
    !FRenderingThread::Run()
    !FRunnableThreadWin::Run()


    #2
    Hello Carlo,

    This is a known issue currently being tracked at: https://issues.unrealengine.com/issue/UE-62486

    As a workaround you should be able to manually show/hide splash screens.

    Hope that helps!

    Comment


      #3
      Hey,
      The problem is still present when I show splash screen on one level and hide it on another, after load. I cannot find a workaround on it.
      Could you guide me what should I do?

      Comment


        #4
        I am getting the same error when using the new multi-viewer template. Has this been fixed?
        Attached Files

        Comment


          #5
          Woodyonehundred3 I am getting that error message too, but in here it said that the bug is fixed : https://issues.unrealengine.com/issue/UE-62486

          Comment


            #6
            Hi,
            I'm pretty mush a beginner in UE4. I spent hours in the MultiUserViewer template trying to create a session with 2oculus rift headsets ( on different computers ).
            Only after i broke the link to "set splash screen" did the exe finally start working as it should.
            I used UE4 4.22.2

            Comment

            Working...
            X