Announcement

Collapse
No announcement yet.

[SOLVED] VR Preview option blacked out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [OCULUS] [SOLVED] VR Preview option blacked out

    Trying to create a simple VR game. Here's what I did:
    Run UnrealEngine 4.20 (Administer and regular)
    New Project
    I've tried VR Project, and blank, with Mobile/tablet + 2D/3D scalable, and Computer/PC with Maximum Quality.
    With the Computer/PC it crashes the game + editor if I try to run the game in VR (I have Oculus Rift)
    With the Mobile/Tablet the first time I tried it just crashed me, now the option is just blacked out.

    Now with non admin + PC/Computer + VR Template, the VR Isn't blacked out but it still crashes UE4 and the editor
    Enabled Oculus Beta still nothing

    I just had to update my video drivers.
    Last edited by Big_Bad_E; 09-21-2018, 05:52 PM.

    #2
    Hello,
    when you have your Oculus rift are you having oculus home and experience your home without problems?
    Regarding UE4 did you tried the VR template BP ?

    Comment


      #3
      Originally posted by J_Tox View Post
      Hello,
      when you have your Oculus rift are you having oculus home and experience your home without problems?
      Regarding UE4 did you tried the VR template BP ?
      Yes my home is problemless, same with UE4 games, Steam games, etc...
      BP? I don't know what that means, but I tried all combinations of options with VR template.

      Comment


        #4
        Now the preview button isn't greyed out, but VR preview still crashes.

        Comment


          #5
          I'm going to bump as this has gotten 0 responses.

          Comment


            #6
            You may have plugins conflict. Make sure that in the VR section of the plugins only the Oculus VR one is active. Then restart everything and try again.
            CTO | Head of VR Development - Visit us at http://humanxr.com
            My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

            Comment


              #7
              Originally posted by vr_marco View Post
              You may have plugins conflict. Make sure that in the VR section of the plugins only the Oculus VR one is active. Then restart everything and try again.
              SteamVR was enabled, but after disabling it UE4 + the game still crashes. Thanks for the idea though.
              Last edited by Big_Bad_E; 09-20-2018, 07:18 PM.

              Comment


                #8
                Originally posted by Big_Bad_E View Post

                SteamVR was enabled, but after disabling it UE4 + the game still crashes. Thanks for the idea though.
                Do you get any crash log? There is a link to them from the crash window. They usually help understand what caused the crash. You can share them here.
                CTO | Head of VR Development - Visit us at http://humanxr.com
                My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                Comment


                  #9
                  https://pastebin.com/xnCsdibP

                  Comment


                    #10
                    Ok there is something else.
                    Try a new project with VR template WITHOUT the default Starter content.
                    ( By BP I mean not C++)
                    Last edited by J_Tox; 09-20-2018, 08:59 PM.

                    Comment


                      #11
                      Skip the VR template and go for an empty project, add a Pawn blueprint, add a camera to the blueprint (if there isn't one), in the camera details set to use HMD rotation, in the gamemode set the pawn to be the default pawn. Make sure there's something in the scene to look at so it's not just black space.

                      Comment


                        #12
                        Originally posted by Big_Bad_E View Post
                        Had a look at the log file. Looks like a video drivers issue to me. The crash seems to happen as soon as the render target for the Oculus is allocated. Did you try to update your video drivers?
                        CTO | Head of VR Development - Visit us at http://humanxr.com
                        My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                        Comment


                          #13
                          Originally posted by vr_marco View Post

                          Had a look at the log file. Looks like a video drivers issue to me. The crash seems to happen as soon as the render target for the Oculus is allocated. Did you try to update your video drivers?
                          I've been wanting to update them, looks like the perfect excuse. Thanks for the help.

                          Comment


                            #14
                            Just a bit of googling, and everything is good
                            Drivers are updated! Its working!

                            Comment

                            Working...
                            X