No announcement yet.

DayDream app Splash Screen

  • Filter
  • Time
  • Show
Clear All
new posts

    [Daydream] DayDream app Splash Screen

    Hello everybody, I've tried without success adding the [Daydream.Splash.Settings] to the DefaultEngine.ini config file, and also applied the image as a texture inside the scene just to be sure it's packaged, but no luck whatsoever.
    I've noticed the ways of the launch image change with engine version, so i'm asking you: what is the "default" or "correct" method for adding a Launch Image to a 4.20.2 project for DayDream?
    thanks in advance

    I've not tested it yet in 4.20 but another good place to ask is over at the GoogleVR plugin Git issuess:
    where sometimes the developer is available to take a look
    Headgear - VR/AR solutions


      Thank you aussieburger, posting there immediately


        Not perfect but we did a few steps forward, we're talking Unreal 4.20.2.

        I created into the Content folder a LoadScreenTextures folder; I opened the project in UE4, then I dragged into the LoadScreenTextures the texture (as a .png file named loadingScreen_daydream) that I wanted for my loading screen.

        I opened Settings -> Project Settings, went to Packaging -> Packaging-> Expand -> Additional Asset Directories to Cook. I added there the LoadScreenTextures folder.

        Then I added to the DefaultEngine.ini (located in the Config folder) the following lines:

        TextureUVOffset=(X=0.0, Y=0.0)
        TextureUVSize=(X=1.0, Y=1.0)

        Note that the Game directory is seen as the Content directory, so leave that untouched.

        This solved only partially my problem.

        After launching the installed UE4 project, from the Lenovo Mirage Solo, the screen still remains black for an hefty amount of time, then the loading screen appears, then it's quickly loaded the first stage of the game.

        so we're still looking for a better solution, with the loading screen appearing shortly after the launch of the application



          papalagi Did you ever find a good solution to this? I am hoping to also overcome the issue of a long-running black screen while loading.