Announcement

Collapse
No announcement yet.

[GO] objects turn white

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [GO] objects turn white

    Having a small problem on the GO. Sometimes, objects turn totally white on the GO - see pic / movie. It only happens on the GO, not on Rift or desktop.

    In several projects, I notice objects sometimes turn white when loading the streaming level a second time. Most of the time only the trees, sometimes everything on the streaming level.
    The trees are on the persistent level, streaming levels have a lighting scenario.

    Anyone a clue what could trigger this and how to fix it?

    Small movie here https://youtu.be/LZoSllxjQl8

    #2
    Some more info after again (and again and again) looking into this problem;

    0. the problem is only when viewing on the Oculus GO. Not on desktop/Rift.
    1. at the start (begin play) all streaming levels are pre-loaded. Only one streaming level has its visibility set to true by blueprint.
    2. because of 1, when switching to another streaming level, the switch is instant (visibility is set to true for the 'new' streaming level, set to false for the previous streaming level).
    3. in many projects, at some point some streaming level, when visited for the second (or more) time, the streaming level in whole or some objects in the streaming level will turn bright white. Switching the streaming level to another streaming level sometimes fixes this (after switching to other levels a few times).

    My guess is: its a memory thing. It seems to occur more often when the complexity/resolution of textures/lightmap density increases. It could also explain why it happens on the GO; the GO has far less memory than the gtx 1080 in the system.

    A 'solution' to this problem is loading and unloading a streaming level when you need it and then the problem doesn't occur. But this results (when switching streaming levels) in a few seconds hickup (on the GO) which isn't nice for the user experience.

    I tried increasing the streaming poolsize by 'Execute console command: r.Streaming.PoolSize _3000' but that doesn't help.

    Edit: In the player blueprint, adding a node 'Execute console command: r.Streaming.PoolSize 3000' so without the '_' makes the problem (almost) go away. It rarely happens now.
    Last edited by maxbrown; 09-25-2018, 10:11 AM.

    Comment


      #3
      Hi Max, is this something you can reproduce easily or does it show up only when the projects are very complex? Any hints coming from the debug log?
      CTO | Head of VR Development - Visit us at http://humanxr.com
      My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

      Comment


        #4
        Hi Marco,
        Alas, it can't be reproduced easily. It only shows up when projects get more complex - more geometry, textures, bigger lightmaps etc etc.
        I tried modifying Epic's Suntemple project to get the problem in there as well but had to stop due to work. When I have time again I will continue because it would be nice to have this problem fixed alltogether.

        edit: a few errors in the log but nothing useful or related to streaming levels (I think):

        LogScript: Warning: Accessed None trying to read property RightController
        LogPlayLevel: MCPawn_180903_C /Game/start.Start:PersistentLevel.MCPawn_3
        LogPlayLevel: Function /Game/00_libs/blueprints_180903/MCPawn_180903.MCPawn_180903_C:ExecuteUbergraph_MCPawn_180903:0039
        LogPlayLevel: : LogScript: Warning: Script call stack:
        LogPlayLevel: Function /Game/00_libs/blueprints_180903/MCPawn_180903.MCPawn_180903_C:InpActEvt_GrabRight_K2Node_InputActionEvent_0
        LogPlayLevel: Function /Game/00_libs/blueprints_180903/MCPawn_180903.MCPawn_180903_C:ExecuteUbergraph_MCPawn_180903
        Last edited by maxbrown; 09-26-2018, 06:53 AM.

        Comment


          #5
          Those lines are related to the handling of the pawn input. They don't seem related to level streaming. Anything else that stands out to you in the log file?
          CTO | Head of VR Development - Visit us at http://humanxr.com
          My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

          Comment

          Working...
          X