Announcement

Collapse
No announcement yet.

Is there anybody out there using streaming media in vr projects?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Is there anybody out there using streaming media in vr projects?

    Out of curiosity, is there anybody out there that uses media streams in his mobile vr projects?
    I don't find anything about this in the internet, no best practices, questions or answers.
    Is it a bad idea to do so? Or are there better ways? I want to give my app to others and update the video content on my side without having them to do anything.

    Cheers
    Evil_Fischi

    #2
    Have a look at UE4's Media Framework here: https://docs.unrealengine.com/en-us/...MediaFramework
    CTO | Head of VR Development - Visit us at http://humanxr.com
    My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

    Comment


      #3
      Thank you vr_marco for the link. How can I see the logs from the troubleshooting tip on my oculus GOs?


      What I am up to is to launch the app on the device and give it to someone to watch the videos. But I also want to exchange those videos when I have new ones without having the others to update something. So now I would only exchange the existing video on the server and the viewer could directly watch my new videos.

      I am using four H.264 videos with a bitrate of 2038kBit/s and 25 frames per second and with the following sizes
      - 1344x420 and audio (317kBit/s, stereo, 48kHz)
      - 1344x504
      - two times 672x504

      The devices are all fresh, there is nothing more than the launched project on them. They have all the newest versions installed.

      When the level starts I load all four sources and after a delay of two seconds they are set to play.

      What happens:

      On some devices everything works more or less. The streams are about one or two frames off sync but I think this comes from the stream, but overall they run. When I start the app again in the GO sometimes one of the stream does not load at all.
      On other devices one or two streams don't load but this happens everytime I start the app again.

      I have also set up a function to seek forward but then it often happens, that the streams are offsetted even more. I stop evey media player, delay for one second, seek to the new time, delay again and then play all of them.

      Are there any hints you can give me on what I am doing wrong?

      Greetings
      Evil_Fischi

      Comment


        #4
        Regarding how to get your debug logs out of the Oculus Go, please see here: https://developer.oculus.com/documen...#mobile-logcat

        About synchronizing video streams across multiple devices, I am not familiar with this topic so I cannot really help. I am sure there are ways to do it (E.g. services which allow you to watch a YouTube video in synch with your friends) but due to latency and other factors I don't believe it can be 100% perfect. At least this has been my experience.
        Last edited by vr_marco; 05-31-2018, 08:33 AM.
        CTO | Head of VR Development - Visit us at http://humanxr.com
        My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

        Comment


          #5
          thanks for the link.
          But you misunderstood me concerning the sync. I just meant that on one device the movies are off sync with one or two frames. I don't want to sync the videos with other device, I just want them to play them all parallel on one device without the offsetted frames.

          Comment


            #6
            Ok got it. What prevents you from stitching them together in a video editor and playing everything as 1 single movie? In this way you won't have any synch issue.
            CTO | Head of VR Development - Visit us at http://humanxr.com
            My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

            Comment


              #7
              I thought of that as well, but I am afraid that this would result in a pretty big video and I don't know if the resolution is then too big for it.

              Comment

              Working...
              X