Announcement

Collapse
No announcement yet.

wavy render issue, only in headset.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [OCULUS] wavy render issue, only in headset.

    i cant for the life of me find anything about this and im not sure what is causing it. but when im in editor. or in a launched game. my vr set will give a wavy distort on all effects. especially lighting and bumbmaps. but there's no pattern. its there one day. and gone the next. and that can change in the next hour at random. scene complexity doesn't seem to matter but magnifies it when present. but even simple scenes do it.

    worst of all it never does it on the screen capture. so i cant get footage of it.
    i am using an oculus rift and Ive never seen this until i booted unreal for the first time 4 months ago, and i still dont see it anywere else
    and Ive dealt whit it ever since. default template and settings or complicated scene with deferred or forward render. nothing makes it go away.
    but im not sure its present in a finished build of a game because i haven't seen it in my game jam release, which i played several times.

    can anybody tell me if they've experienced this and how to fix it. its terribly distracting from performance testing and gives all of my test subjects motion sickness.
    Last edited by sphinix257; 05-23-2018, 12:21 AM.

    #2
    Just to discard a possible cause.. are you sure that what you are experiencing is not the pupil swim which is a known problem/tradeoff of the Oculus Rift? The swivel mechanism between the HMD and the straps allows rotating the pitch; this makes the Rift adjust better to different types of faces, but it has the tradeoff of introducing pupil swim if the lenses are not properly aligned with your eyes.

    Try focusing on long vertical straight lines of your scene, then turn your head left and right while looking at them and look for distortions. Then try adjusting the pitch of the HMD and see how it makes a big difference. The HTC Vive doesn't have this problem because you can't change the pitch of the HMD in relation to your face, in case you can use one to test.

    Comment


      #3
      What are your system specs? Maybe your seeing artifacts caused by oculus asynchronous spacewarp (ASW). This might happen when your game cant run at 90fps constantly.
      You can try to disable it and see if that helps. INstructions can be found here:
      You can learn more about it here:
      https://developer.oculus.com/documen...ous-spacewarp/
      Also check this out if you want to learn more about it:
      https://developer.oculus.com/blog/as...ous-spacewarp/

      Comment


        #4
        Its certainly a software issue between ether unreal or oculus during in engine testing.

        I have checked and it looks like a rendering issue
        Its motion based in game. If i stand still and look forward. Its clear. If i wave the flashlight and stand still, if waves and distorts the edges if the light. And if i move my head. It distorts the edge of the screen. Kinda like anything that projects like a light or a camera cuases it.
        Last edited by sphinix257; 05-23-2018, 10:10 AM.

        Comment


          #5
          Originally posted by Aerandier_ View Post
          What are your system specs? Maybe your seeing artifacts caused by oculus asynchronous spacewarp (ASW). This might happen when your game cant run at 90fps constantly.
          You can try to disable it and see if that helps. INstructions can be found here:
          You can learn more about it here:
          https://developer.oculus.com/documen...ous-spacewarp/
          Also check this out if you want to learn more about it:
          https://developer.oculus.com/blog/as...ous-spacewarp/
          i just discovered asw before i read your post. and yes. asw turned out to be the issue
          and the scene is fresh and horribly optimized for vr as i didn't create the assets and most of them are 4k and 2k textures that i need to compress and get my levels streaming in.
          i have a bit of a bulky test environment as i work a bit messy in experimental levels before i make real levels.

          but just for reference my system specs are:

          i-5 7th gen
          1070gtx
          16gb ddr4 ram
          os and game running off separate ssd's



          thank you guys. does anybody know of a way to disable asw in final builds. my game requires you have a flashlight. and asw hates the flashlight the most. to the degree of very serious motion sickness inducing. the game becomes unplayable no matter how high the frames get if asw turns on.

          Comment


            #6
            Originally posted by sphinix257 View Post

            i just discovered asw before i read your post. and yes. asw turned out to be the issue
            and the scene is fresh and horribly optimized for vr as i didn't create the assets and most of them are 4k and 2k textures that i need to compress and get my levels streaming in.
            i have a bit of a bulky test environment as i work a bit messy in experimental levels before i make real levels.

            but just for reference my system specs are:

            i-5 7th gen
            1070gtx
            16gb ddr4 ram
            os and game running off separate ssd's



            thank you guys. does anybody know of a way to disable asw in final builds. my game requires you have a flashlight. and asw hates the flashlight the most. to the degree of very serious motion sickness inducing. the game becomes unplayable no matter how high the frames get if asw turns on.
            is your game setup with forward rendering? try enabling that in project settings
            Matt Walton: Programmer and owner for WireLiteSoft Games.

            Comment


              #7
              No. I had initially turned it off. Trying to fix it. And was playing with effects i wasnt able to use in forward render. I could probably go back. But god rays were kinda neat.

              But even with it on. If asw turns on. The flashlight goes rampant.

              Comment


                #8
                And the flashlight and sneaking in dark abandoned environments is the core mechanic of my game

                Comment


                  #9
                  Originally posted by Aerandier_ View Post
                  What are your system specs? Maybe your seeing artifacts caused by oculus asynchronous spacewarp (ASW). This might happen when your game cant run at 90fps constantly.
                  You can try to disable it and see if that helps. INstructions can be found here:
                  You can learn more about it here:
                  https://developer.oculus.com/documen...ous-spacewarp/
                  Also check this out if you want to learn more about it:
                  https://developer.oculus.com/blog/as...ous-spacewarp/
                  This Really helped me! Thank you so much!
                  Game is running amazingly smooth now!

                  Comment

                  Working...
                  X