Announcement

Collapse
No announcement yet.

changing worlds causes me to spawn under the world.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [OCULUS] changing worlds causes me to spawn under the world.

    Hello, I'm new to VR game development but not new to unreal.

    I'm having a really odd issue.
    When i load a level from inside a level using an actor i made as a button
    the game freezes then goes back to oculus home, after a few minutes
    the level loads however now it spawns me under the world if i click on the ground.
    but if i play each level by its self without the Open level it works and there is no issue.
    I can't seem to get it to work.

    I tried setting nav-recast to dynamic in either map and in both and that don't help at all.

    here is a video so you can see what is going on. Please someone have a fix for this issue. I so totally want to get this working.


    Matt Walton: Programmer and owner for WireLiteSoft Games.

    #2
    try a "set tracking origin" node... either when you spawn in.. or maybe you need to zero it as you spawn out? just a guess. gl

    Comment


      #3
      Originally posted by Rocketscott View Post
      try a "set tracking origin" node... either when you spawn in.. or maybe you need to zero it as you spawn out? just a guess. gl
      I already have that in my player pawn http://prntscr.com/jkg2ce
      Matt Walton: Programmer and owner for WireLiteSoft Games.

      Comment


        #4
        Originally posted by frostic View Post
        Hello, I'm new to VR game development but not new to unreal.

        I'm having a really odd issue.
        When i load a level from inside a level using an actor i made as a button
        the game freezes then goes back to oculus home, after a few minutes
        the level loads however now it spawns me under the world if i click on the ground.
        but if i play each level by its self without the Open level it works and there is no issue.
        I can't seem to get it to work.
        Can you try to do Enable HMD with Enable unticked (stereo off) before calling Open Level, then re-enable the stereo mode once you are in the new level. Does it make any difference?
        CTO | Head of VR Development - Visit us at http://humanxr.com
        My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

        Comment


          #5
          Originally posted by vr_marco View Post

          Can you try to do Enable HMD with Enable unticked (stereo off) before calling Open Level, then re-enable the stereo mode once you are in the new level. Does it make any difference?
          You sir are freaking awesome and this fixed my issue. that is one cool trick. I didn't know that node existed.
          Matt Walton: Programmer and owner for WireLiteSoft Games.

          Comment

          Working...
          X