Announcement

Collapse
No announcement yet.

VR Packaged game FPS capped while using spectator mode and HMD removed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VR Packaged game FPS capped while using spectator mode and HMD removed

    I have a level setup with a custom VRPawn and a spectator camera. The behavior that I have created is that when the HMD is not on your head I'm rendering a Media Texture to the spectator screen. Upon receiving the HMDPutOnHead event from the VRNotification system I change the spectator screen mode to SingleEyeCroppedToFill allowing what is being seen through the HMD to be displayed. This all runs perfectly smooth 120FPS on the spectator display and 90FPS in the HMD while in the editor. However, when I package the game and run it in fullscreen, the spectator camera is rendering at 10FPS and my GPU is idling between 4 - 8%. This is leading me to believe that the packaged game is throttling down the CPU/GPU utilization when the HMD is not over your head. The second I put the HMD on I can hear the fans on my graphics card ( 1080 ti ) spool up and HMD is hitting 90FPS.

    I know there is a setting in the editor that allows you to use less CPU when in the background, but I don't know how to force the same for a VR enabled packaged game.

    Click image for larger version

Name:	less_cpu.PNG
Views:	67
Size:	34.7 KB
ID:	1472608

    Is there a way to force this setting in a packaged game either via C++ or blueprints without having to re-compile the engine?



    Attached Files
Working...
X