Announcement

Collapse
No announcement yet.

Vive_Pawn is deleting itself and I am unable to find where or why.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Vive_Pawn is deleting itself and I am unable to find where or why.

    Hello, I've got a doozey of a problem. I've been debugging for weeks and am totally deadlocked. I have created a VR game and my vive pawn is deleting itself. I used content search to find all instances of destroy and nothing. Here's what I learned doing some trial an error testing. For context, I am making a VR Archery game. I figure it was an ideal place for my first major project. When

    00:55 Left arrow mounter anddrew full power headset disconnect
    06:20 First minute no input, second minute spawn arrow, third and fourth minute attach arrow to bow, fifth and sixth minute, release bow to fire, 6:20 headset disconnect
    00:07 No input from player headset disconnect. (Headset may have been out of view of trackers)
    03:52 No Input from player, no disconnect
    00:23 Grabbed arrow at 0:06 , fired, moved headset back, headset disconnect
    00:XX Less than a minute, moved headset out of the way to deliberately lose tracking, and it reconnected twice. Third time disconnect. All happened in less than 60 seconds
    14:50 No input from player for entire time. No headset disconnect
    09:52 No input for 5:30 of no input, 2 minutes of arrow spawned, 2 minutes of arrow aimed, 15 seconds after firing, headset disconnect.
    10:55 FRESH PROJECT Plenty of input from both controllers, teleported, grabbed objects, and threw them. No disconnect

    Multiple Deliberate headset Disconnects in fresh UE4 VR Project to prove maybe it is code (Which seems redundant because the destroy function is being called roguely somewhere but I will include this for debugs Sake, this is a 4.18 version of the motion Controller Pawn.)

    DC Time - RC time
    00:05 - 00:11
    00:18 - 00:21
    00:25 - 00:28
    00:34 - 00:37
    00:42 - 00:45
    00:52 - 00:56
    01:00 - 01:03

    In total this results in 7 deliberate disconnects, in just over a minute with 7 succesful reconnects. (The headset losing tracking, and gaining tracking again. The reason that I know that the destroy function is being called is due to the fact that I bound an event to the destroy function during play, and set a break point and it stopped. it doesn't seem to want to print though which is very strange. If anyone has any insight, that'd be great. because I have none. I think at this point it's either a hardware issue, or a Unreal Engine Issue. I have my pawn set to place in world or spawned, I have it placed in the world. Actor lifetime is set to 0. So is the auto logout setting.
    Last edited by J3WD4Z; 03-08-2018, 08:31 AM.
Working...
X