Announcement

Collapse
No announcement yet.

VIVE Steam VR Unresponsive in 4.18 and 4.17

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VIVE Steam VR Unresponsive in 4.18 and 4.17

    I posted this in answerhub already but received no response. Hopefully someone here can help as I'm out of options.

    Starting yesterday (2/23/2018) whenever I launch UE4 (4.18.3), the SteamVR window displays in red "(unresponsive) UE4Editor.exe".

    If I try to run my level in VR Preview the VIVE only displays a default SteamVR loading environment with UE logo and loading animation. However, the mirrored display on the monitor appears to show the VIVE tracking and functioning normally. This also occurs in a blank project in 4.17 and 4.14.

    Sometimes, while in VR Preview, if I wait a random amount of time or type tilde to enter a console command, the SteamVR window "unresponsive" message will disappear and the HMD operates normally. However, once I exit VR Preview and try it again, UE4 falls back into the "unresponsive" state.

    If I run a packaged project from 4.18.3, the HMD works as expected every time.

    The VIVE also works as expected in Unity and all SteamVR apps I have tried so far.

    Console commands like "vr.bEnableStereo True" etc. seem to have no effect.

    Specs:
    Windows 10 (version 1709)
    GeForce 970 (84.4.84.0.2c)
    SteamVR 2018-02-09
    HTC VIVE Pre

    Any thoughts for how to troubleshoot this would be much appreciated. I really can't understand why the VIVE works as expected everywhere but the Unreal Engine editor.
Working...
X