Announcement

Collapse
No announcement yet.

Quick AR Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Quick AR Problem

    Just about through the guide for ARCore and ran into a problem. https://developers.google.com/ar/dev...eal/quickstart
    When trying to open I get this error #1 below.
    After pressing through, I get this error #2 below.

    Help please?

    #2
    That's plugin issue. Right click *.uproject file, open with Notepad and post what you got there. Are you building from source as in this guide or is it binary launcher version of the engine ?

    Normally, your *.uproject file should have something like this:

    Code:
    {
        "FileVersion": 3,
        "EngineAssociation": "4.19",
        "Category": "",
        "Description": "",
        "Plugins": [
            {
                "Name": "GoogleARCore",
                "Enabled": true
            }
        ],
        "TargetPlatforms": [
            "Android",
            "IOS"
        ]
    }
    VR/AR Development [Portfolio | YouTube | LinkedIn]

    Comment


      #3
      It contains this:

      Code:
      {
          "FileVersion": 3,
          "Category": "",
          "Description": "",
          "Modules": [
              {
                  "Name": "HelloARUnreal",
                  "Type": "Runtime",
                  "LoadingPhase": "Default",
                  "AdditionalDependencies": [
                      "Engine"
                  ]
              }
          ],
          "Plugins": [
              {
                  "Name": "GoogleARCore",
                  "Enabled": true
              },
              {
                  "Name": "OculusVR",
                  "Enabled": false
              },
              {
                  "Name": "SteamVR",
                  "Enabled": false
              },
              {
                  "Name": "OnlineSubsystemGooglePlay",
                  "Enabled": false,
                  "SupportedTargetPlatforms": [
                      "Android"
                  ]
              },
              {
                  "Name": "OnlineSubsystemIOS",
                  "Enabled": false,
                  "SupportedTargetPlatforms": [
                      "IOS",
                      "TVOS"
                  ]
              }
          ]
      }

      Comment


        #4
        Is engine a source or binary build ?
        VR/AR Development [Portfolio | YouTube | LinkedIn]

        Comment


          #5
          Got all to work. This is the Hello AR Project testing.
          Solution, reinstall again with Visual Studio 2015, not 2017. Not 100% if this is what fixed it, but it works now..

          Comment

          Working...
          X