Announcement

Collapse
No announcement yet.

Getting some bad artifacts with a plaid texture in VR

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Getting some bad artifacts with a plaid texture in VR

    Hey all - I have this plaid texture on this couch. When viewed in VR and not moving your head around, it looks fine. But once you start moving your head and looking at the couch, it starts to get all kinds of crazy warping/artifacts. This is at its worst when you move your head in circular motions. It's totally fine on a computer monitor, it's only when viewed in VR it gets all these issues. I also tried changing all the AA settings to no avail.

    Unfortunately changing the texture isn't really an option. As a test, I tried making the plaid texture all very light colors, but I still got the issue just as bad.

    So if there are any workarounds or settings I can change, that would be great. But I have a feeling it's more complicated than a check box...

    #2
    Are you using the Forward Renderer with MSAA? How does the geometry of the couch look like? Do you have a lot of fine details?

    Did you try to look through the different view modes to see if you can relate the effect to any particular issue (shader complexity, LOD's, etc.) ?
    CTO | Head of VR Development - Visit us at http://humanxr.com
    My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

    Comment


      #3
      Originally posted by vr_marco View Post
      Are you using the Forward Renderer with MSAA? How does the geometry of the couch look like? Do you have a lot of fine details?

      Did you try to look through the different view modes to see if you can relate the effect to any particular issue (shader complexity, LOD's, etc.) ?
      This was it! Turning on Forward Rendering fixed the issue! Mind explaining why? Thanks so much!

      Comment


        #4
        I suspect the issue was caused by Motion Blur. When switching to the Forward Renderer motion blur is turned off.
        CTO | Head of VR Development - Visit us at http://humanxr.com
        My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

        Comment


          #5
          hate to bring this topic back - but I transfered this project to my laptop and now the issue is back even with forward shading turned on.

          What on earth could cause it to not work on the laptop, but works fine on desktop? Laptop is using a GTX1060.

          Comment


            #6
            Originally posted by mobkon View Post
            hate to bring this topic back - but I transfered this project to my laptop and now the issue is back even with forward shading turned on.

            What on earth could cause it to not work on the laptop, but works fine on desktop? Laptop is using a GTX1060.
            Are you using Oculus or Vive or what?
            CTO | Head of VR Development - Visit us at http://humanxr.com
            My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

            Comment


              #7
              Originally posted by vr_marco View Post

              Are you using Oculus or Vive or what?
              Oculus. Tried messing with tons of settings last night in UE4 - tried forward shading on/off, all different types of AA options, and nothing is working. Really weird to me that just turning on Forward Shading on my desktop worked fine, but when i tranfered the project to my laptop, it still had the issue even though forward shading was turned on. Motion Blur is also off.

              Comment


                #8
                Originally posted by mobkon View Post

                Oculus. Tried messing with tons of settings last night in UE4 - tried forward shading on/off, all different types of AA options, and nothing is working. Really weird to me that just turning on Forward Shading on my desktop worked fine, but when i tranfered the project to my laptop, it still had the issue even though forward shading was turned on. Motion Blur is also off.
                Did you try also with a standard project? Brand new VR template. Or that one works?
                CTO | Head of VR Development - Visit us at http://humanxr.com
                My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                Comment


                  #9
                  Originally posted by mobkon View Post

                  Oculus. Tried messing with tons of settings last night in UE4 - tried forward shading on/off, all different types of AA options, and nothing is working. Really weird to me that just turning on Forward Shading on my desktop worked fine, but when i tranfered the project to my laptop, it still had the issue even though forward shading was turned on. Motion Blur is also off.
                  Ok, so opening a new VR template and importing the problematic mesh/textures in, seems to work absolutely fine once I enable Forward Shading. Strange.

                  Now i need to figure out how to take my whole project and import it into the VR template

                  Comment


                    #10
                    Originally posted by mobkon View Post

                    Ok, so opening a new VR template and importing the problematic mesh/textures in, seems to work absolutely fine once I enable Forward Shading. Strange.

                    Now i need to figure out how to take my whole project and import it into the VR template
                    You can migrate an entire level and its dependency from the old project to the new one using the Migrate... function.
                    CTO | Head of VR Development - Visit us at http://humanxr.com
                    My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                    Comment

                    Working...
                    X