Announcement

Collapse
No announcement yet.

VR World Scale

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VR World Scale

    Hi, I've built an scene using 1st person template of an Apartment, migrated to VR and tested with Vive. In VR, it is not to scale, everything is too small, I need to scale up my world by around 30%, any suggestions?

    Thanks
    Graeme van Rensburg
    Email: graeme@designgvr.com

    #2
    Preliminary questions: 1. did you use the proper scale units in your 3d modeling software? (e.g. in Blender you need to set the scene to use cm intstead of the default meters) 2. Did you apply any scale factor on import?

    Anyway, instead of scaling the world, you could re-import everything by applying a 1.3 scale factor so you don't need to touch the World Scale.
    CTO | Head of VR Development - Visit us at http://humanxr.com
    My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

    Comment


      #3
      I modeled everything in 3ds max in Feet and inches? So I need to convert the units from feet to cm inside max, then reimport everything from Max into Ue4? Is there no way to do this inside Ue4 as I've already done so much work in Unreal, adding materials, lighting etc. Thanks for you help.
      Graeme van Rensburg
      Email: graeme@designgvr.com

      Comment


        #4
        Hey,
        you could play around with the World to Meters Settings @ World Settings -> VR. That sould work.
        Or attach your whole apartment to one actor and set a different scale in that actor so that your world is scaled up.
        Best,
        ZABBA


        Comment


          #5
          What setting would I need to change the World to Meters settings if I want everything bigger by 30%? It is currently at 100. Thanks for you help.
          Graeme van Rensburg
          Email: graeme@designgvr.com

          Comment


            #6
            You have to be careful with WorldToMeters if you are on 4.18, it uses a new late update method that breaks with world to meters settings that aren't 100.0f (the default). Basically it treats it visually like the controllers are using WorldToMeters 100.0f while the game thread uses the correct setting causing them to have a visual offset.

            You can turn off late updates to correct for it as a temp solution.

            Also lower numbers of WorldMeters = smaller player = larger world *Edit* Brain fart
            Last edited by mordentral; 11-15-2017, 11:05 AM.


            Consider supporting me on patreon

            My Open source tools and plugins
            Advanced Sessions Plugin
            VR Expansion Plugin

            Comment


              #7
              That value indicates how many Unreal Units correspond to 1 meter. If you want to increase the perceived size of the world by 30%, you have to decrease that number to 1/1.3*100 = 76.92. Give it a try and check how it feels.
              CTO | Head of VR Development - Visit us at http://humanxr.com
              My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

              Comment


                #8
                Well 100 says that 100 units in game are one meter for your VR experience.
                If you wanted the world to be 30% larger, then you would want less than 100 world units to be one meter in your VR experience.
                So you should set it at about 70 if I am correct.
                But you can play around with that setting until it fits your world.

                Comment


                  #9
                  Great, thanks so much for help guys
                  Graeme van Rensburg
                  Email: graeme@designgvr.com

                  Comment


                    #10
                    Originally posted by vr_marco View Post
                    That value indicates how many Unreal Units correspond to 1 meter. If you want to increase the perceived size of the world by 30%, you have to decrease that number to 1/1.3*100 = 76.92. Give it a try and check how it feels.
                    Whoops, this is correct


                    Consider supporting me on patreon

                    My Open source tools and plugins
                    Advanced Sessions Plugin
                    VR Expansion Plugin

                    Comment


                      #11
                      Well, adjusting World To Meters in 4.18 seem super bugged to me. When i do that, it offsets my floor level. It may only be happening if i pause the game (call Pause game node), but never the less, it behaves radically different from 4.17 (bugged). I've written up a question on answerhub, if someone would like to test it out, and possibly vote it, if they think this is a relevant thing to get addressed.

                      https://answers.unrealengine.com/que...d-widgets.html

                      Comment


                        #12
                        Thanks for the feedback Jonas, I have yet to test it, but will do so and follow up.
                        Graeme van Rensburg
                        Email: graeme@designgvr.com

                        Comment


                          #13
                          Originally posted by Graeme VR View Post
                          Thanks for the feedback Jonas, I have yet to test it, but will do so and follow up.
                          It could be indeed a better idea to re-import all the meshes while applying a 1.3 scale factor to them. Or go back to your 3D modeling application, scale everything to 130%, then re-export and re-import into UE4. But this you knew already I guess.
                          CTO | Head of VR Development - Visit us at http://humanxr.com
                          My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                          Comment


                            #14
                            Out of curiosity, would this also work for scaling the AR camera world? so scaling down large buildings from Max wouldn't be a worry? you could compensate with the VR World to Meters value?
                            Modeller and many other things at Visualisation One

                            Comment

                            Working...
                            X