Announcement

Collapse
No announcement yet.

HUD Elements - No Depth Test / Custom Depth

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HUD Elements - No Depth Test / Custom Depth

    I need some help with a serious issue: We're on 4.17.1 and try to render HUD elements for VR that are part of the world space, ...but since they're HUD elements, we want them to render in front of everything else in the world.

    We set "Disable Depth Test" in material properties, but it simply doesn't work (maybe because of the UMG HUD widget?). We went on with "custom depth" tests but didn't really get it to work. We probably just don't understand the principles of "custom depth".

    Long story short: Can anyone point us the right direction with rendering VR-HUDs using UMG widgets in front of everything in the world? Or maybe there's some tutorial that reveals more about this subject? Any help is highly appreciated.

    #2
    It's easy.

    You need two things

    Create the Widget, obviously, then put the widget component in an Object or in the Character if the Widget is a HUD. And assign to the Widget Component a material with Disable Depth (In my case, WidgetSeeThrough)

    Two Pics to illustrate.

    PD: Shader is a Material Domain -> Surface, Blend Mode -> Traslucent and Shading Model -> Unlit
    Attached Files
    Last edited by Aidan Puche; 09-11-2017, 11:57 PM.
    Viar Warfare - My first VR Game
    I'm Spanish, sorry about my english, i working on it every day.

    Comment


      #3
      I thought we did it like you explained, but we must have overlooked something.
      Following your tips step by step we got it too work! Thanks a bunch, Aidan.

      Comment


        #4
        Great! You are Welcome!

        One Tip, set the HUD OnlyOwnerSee if the Game is Multiplayer, if not, all the player see the Others Player HUD floating in the MAP.
        Viar Warfare - My first VR Game
        I'm Spanish, sorry about my english, i working on it every day.

        Comment


          #5
          That worked! However, how would you do this if you'd want to use widget interaction with this? Say the widget is below the floor and still showing because of Disable Depth Test, but tracer is tracing the floor, (which can also be interacted with). The thing with Unreal is that once you solve one problem, a new one arises.

          So ideally when the widget is spawned (flipflop with grip button), it should somehow override all tracers with the one tracer for the 3d widget.

          Any ideas?

          Comment

          Working...
          X