Announcement

Collapse
No announcement yet.

Why is everything so ugly in the VR template? What am i doing wrong?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why is everything so ugly in the VR template? What am i doing wrong?

    Hi guys,
    i am developing a game for months allready. Its for the Vive, and everyday its getting worse in accepting how ugly everything is. I tried all kinds of things allready, like this:

    r.SetRes 2160x1200 and r.ScreenPercentage 140 and MSAA in the projectsettings, and forward shading (forward shading, that ruins all the foggy stuff big time)
    Certainly the MSAA is really bad, look at the pictures. And thats one of the things epic advices to use in the VR template. I just has to be better i guess. I know the Vive is perfect, because when i play a demo like the Lab, it looks just soo good.
    Even in a blank level with almost nothing its ugly. Is there somebody with some advice?
    I have put all the settings in the epic mode and also the materials. I use a pretty fancy gtx 1080 computer. I think thats all not the problem.
    Perhaps 4.17 is better? I use 4.16 right now.

    #2
    This is with forward shading and MSAA. And the translucent water which is beautifull,.. is gone

    Comment


      #3
      I believe one of the reasons it doesn't look good is that you are using Normal Maps instead of real geometry.

      Due to stereoscopic vision Normal Maps do not work well in VR. Especially when you look at something from the side it still appears flat and its surface will look rather fake. Normal Maps are usually ok for smaller details and high LOD's but not for low LOD's and LOD0 in particular.

      Of course there are always exceptions to the rule. Displacement maps with some level of tessellation may also help, but nothing looks as good as a detailed geometry.

      Hope this helps!

      Cheers,
      Marco.
      CTO | Head of VR Development - Visit us at http://humanxr.com
      My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

      Comment


        #4
        thanks Marco, thats a good one. Any improvement is more than welcome. At monday i can try the difference. But you are right i guess, i allready removed some normal maps which were a bit over the top. But i should just delete them all. Hope i get it better soon, because the fun of VR/ UE4 goes away slowly because of all this bad graphics!

        Comment


          #5
          Translucent materials work with Forward Shader, but some other features, including screen space reflections, doesn't work. Try to add reflection capture spheres above the water. If you use refraction, switch it to Pixel Normal Offset mode in material properties. It also makes sense to try different light mobility settings. Forward shader is definitely worse, but you still can get really good result with it. You just need to use slightly another approach.

          You can increase MSAA passes by r.MSAACount command. Sometimes it gives cheaper result then too large screen percentage.

          Good luck.
          Last edited by YuriNK; 08-26-2017, 09:34 AM.
          Stand-alone mocap app for Vive Trackers: vrmocapstudio.com
          Marketplace: Vive Mocap Kit / Fingers Solver / VR IK Body Solver / Subtitles to LipSync / Dialogue System with Character Animation
          And random stuff at Youtube

          Comment


            #6
            I asked about Normal Maps looking pants a few weeks back and someone suggested that I use Bump Offset to improve the depth.

            I haven't tried it out myself yet but you can find the documentation here if you want to give it a go:

            https://docs.unrealengine.com/latest...To/BumpOffset/

            Comment


              #7
              well i tried a lot this morning. Seems the forward shading and the MSAA is a really bad choice for me. The best result till now is removing most of the normal maps and use default shading in the project settings. And set the screenpercentage on 200. All objects very close look good, but still objects and landscape further away jitters a lot. Still not figured out how to solve that. Trying more settings the rest op the day

              Comment

              Working...
              X