Announcement

Collapse
No announcement yet.

Oculus SDK 0.4.1 now available with UE4 integration patch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Oculus SDK 0.4.1 now available with UE4 integration patch

    Got an email from Oculus that SDK 0.4.1 is now released:
    https://developer.oculusvr.com/?action=hist

    The email also says : "UE4 integration patch is now available that supports 0.4 SDK and runtime" . However, it does not say that in the version history log on the site.
    I'm at work now so I haven't had any time to look at it but thought I'd let you know.

    #2
    I opened up UE4 and clicked verify and it downloaded a ~300KB patch. I'm guessing that is the patch.

    Comment


      #3
      That may be true for the pre-built version of UE4 4.3.1, but for those of us that build from source, we will need an update/patch. Poking around GitHub I see some changes to the master branch that may be for SDK 0.4.1, but I don't think they have been applied to either UE4 4.3.1 or 4.4 preview.

      - Dave
      Latest Demo, Turtle VR: http://www.turtlevr.com
      Mobile VR Jam 2015 Entry: Circumpaint
      VR game, Here Come The Dead: http://www.herecomethedead.com/
      Main web site: http://www.gnometech.com/

      Comment


        #4
        I was about to ask how I integrate this patch into 4.3.1 source but I guess we're out of luck. Seems like I will have to uninstall 0.4.1 runtime in order to get my game running (and re-install the 0.3.x camera driver).

        Edit: You can get around it (with 0.4.1 installed) like this:
        1) Using the Oculus icon in the taskbar switch display mode to 'Extend Desktop';
        2) Using the same icon, run the 'Configuration Utility', go to the 'Tools' -> 'Advanced' -> 'Pause Service...'. The service will be automatically restarted once you run 0.4-based app.
        2ndEdit: Seems like Oculus might put up a 'UE4 integration package' on their download page today that will update the 4.3 codebase: https://developer.oculusvr.com/forum...165312#p165312

        3rd: I changed to Oculus fork of Unreal Engine. I'll switch back again with 4.4 or 4.5 when 0.4.1 is officially implemented.
        Last edited by Wollan; 08-12-2014, 05:13 AM.

        Comment


          #5
          I do hope it gets integrated in the 4.4, but I'm afraid they are already finalising the release, so we will probably have to wait 4.5.
          Any feedback from Epic?

          Comment


            #6
            Ok, here it goes:
            https://developer.oculusvr.com/forum...165312#p165312
            "We are working with Epic to integrate this code to upcoming UE4 4.4, will see how it goes (can't promise anything; in worst case scenario we will provide our own integration for 4.4 as well)."
            Let's cross our fingers ;-)

            Comment

            Working...
            X