Announcement

Collapse
No announcement yet.

Locked to 60fps in with Rift (but Couch Knights isn't!)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Locked to 60fps in with Rift (but Couch Knights isn't!)

    This is copied from my reddit post that unfortunately was mostly ignored, with no answers forthcoming:

    I'm trying to fiddle with UE4 to make it usable to develop for the Rift DK2. I'm using the default first-person template, and tracking etc works but there's bad judder.

    Running statFPS, it's clear that when I switch to "stereo on" I'm locked to 60fps, which explains the judder. When stereo is off I get >220fps. I know there will be a performance hit, but I'm very obviously being limited to 60fps here.

    So I loaded up Couch Knights in the editor (downloaded from marketplace) and found the same problem. Runs at ~200fps without stereo, exactly 60fps with.

    Then I loaded up the packaged version of Couch Knights which can be downloaded from the Rift Arcade. Smooth as anything! I'm getting >150fps easily in stereo mode.

    I tried making a packaged version of the first-person template, it has the same problem - locked to 60fps when I enter stereo mode.

    So what's the problem? UE4 can obviously drive the Rift at 75Hz easily with the 0.3.2 SDK, given a simple enough scene. What's the difference between Couch Knights launched from the editor and not - where does this hard limit come from?

    Possibly relevant info: i5 4570, EVGA GTX780 oc. I'm launching from the editor in standalone mode, then doing "stereo on". Rift is in extended mode, OVRService etc. killed with Bilago's tool. I've tried with vsync on & off in Nvidia panel, and also tried using the Rift as my primary display. No change, still locked to 60fps.

    I'm quite new to Unreal, it's entirely possible I'm doing something stupid.

    #2
    You probably should check you have the frame rate unlocked in your ini/setup for the project. You can also specify min/max pref framerates - google it.

    Comment


      #3
      Go to:

      Edit -> Project Settings -> Engine -> General Settings -> Frame Rate

      and disable the "Smooth Frame Rate" or increase the min/max range.
      Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

      Comment


        #4
        Thanks for your replies! I had already tried with "Smooth Frame Rate" both on and off.

        How would I check if the frame rate is unlocked? I'm not sure this is the culprit though. When I load the game in standalone mode I get >200fps. Then I open the console, type "stereo on" and I'm instantly locked to 60fps. If it shows >200fps before I turn on stereo mode, surely that means the frame rate is unlocked?

        Comment


          #5
          Also check this thread about 'main monitor' or DK2 is locked to 60hz. May have nothing to do with this but worth a check (even though you had some DK2 stuff running above 60 anyway...)

          https://forums.unrealengine.com/show...us-Runtime-0-4

          Comment


            #6
            Originally posted by Sharpfish View Post
            Also check this thread about 'main monitor' or DK2 is locked to 60hz. May have nothing to do with this but worth a check (even though you had some DK2 stuff running above 60 anyway...)

            https://forums.unrealengine.com/show...us-Runtime-0-4
            I just tried with the Rift as primary display. I made sure to set it as the primary display before launching UE4. Oddly enough, performance was even worse - only 14fps!

            Comment


              #7
              For anyone else who has this problem, I managed to fix it by making a packaged version, then editing the GameUserSettings config file. All I had to do is change FullsceenMode from 2 to 0 (the same as in the packaged version of CouchKnights).

              Now I'm gettting ~150fps! This also has the effect of automatically opening the game full-screened on the Rift, in stereo mode. Strange that this was causing me to be locked to 60fps.

              Does anyone know if there's a way to make it so that when I hit Play in the editor, the resultant standalone instance of the game has this setting applied? That way I'd really be able to start doing some serious Rift development in UE4.

              Comment


                #8
                that strange, i havent that problem, always begin in rift when package.

                Anyway r.fullscreenmode 0 perhaps help

                when i am in the editor i press play standalone and then press alt+enter and autamatic switch two rift in stereo and vsync to 75fps.
                pd: excuse my english.

                lfw/paid modeling, painting, texturing.

                Comment


                  #9
                  So I have the same 60fps problem when enabling stereo mode, sucks because I'm hitting 200fps with it switched off. Tried all suggestions above with no joy, when i do fullscreenmode=0 I get about 40fps and the picture is dark and discoloured..
                  Fairytale Suite - Free orchestral music for fantasy settings
                  Marathon VR Environments - Simple re-creations of environments from Marathon 1/2

                  Comment


                    #10
                    i hit 180-200fps on the templates and got 60-70 in stereo mode with r9-290. I need disable few things in the template for get 75fps. that it why exist the other thread complaining about performance :/
                    pd: excuse my english.

                    lfw/paid modeling, painting, texturing.

                    Comment

                    Working...
                    X