Announcement

Collapse
No announcement yet.

Performance hit and odd stuttering when compared to SteamVR in 4.17?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I have been struggling with this also and I found that disabling the Geforce Share in game overlay got rid of my stuttering.
    http://nvidia.custhelp.com/app/answe...n-game-overlay

    I'm on the latest nvidia drivers and havent tried a roll back yet.

    Leave a comment:


  • replied
    Yes, the moment you roll back to 384.94 all stuttering whatsoever disappears, no matter if with or without ASW. The specs of the system (a notebook) this was tested on: GTX 1070, i7-6820HK @ 2.7 GHz, 32 GB RAM. This is the standard configuration for the notebooks we hand out to our clients complete with our software/content installed.

    The application we used for testing runs at 45 FPS (as expected), but if your system is affected, you'll notice the slight stuttering already in the new Oculus Home screen. It's a stuttering that feels like it's coming from the tracking primarily. You experience a slight offset or very slight position switch every few seconds. You may argue that "slight" bumps and jitters are not a big deal, but in fact they make prolonged VR sessions unbearable.

    Try it yourself to see the difference. You can find previous NVidia drivers here:
    http://www.nvidia.com/Download/Find.aspx?lang=en-us
    Last edited by Sharkster-NXR; 01-25-2018, 01:48 PM.

    Leave a comment:


  • replied
    Actually 385.xx had quite some VR related changes, so ti could be. And once you installed 384.94 installed everything went magically back to smooth? Also with/without ASW? What are the specs of your machine?

    Leave a comment:


  • replied
    Just like I assumed before, the reason for the weird stuttering and jitters IS NOT UE4 RELATED. The sole culprit in my case are the NVidia drivers.

    I gradually rolled back from the current (390.65) to the late July release (384.94). The short story: There're no jitters and no stuttering in NVidia drivers up to late July. A slight stuttering started to sneak in with the driver released on August 14 (the day this thread was opened!) and seemingly became worse with every subsequent driver update (at least for my machine).

    If your system is affected by this mess, roll back to 384.94 NVidia drivers and you'll be surprised how buttery smooth Oculus Rift once was. Just make sure you do a clean uninstall of your current driver before (e.g. with DDU - "display driver uninstaller"), put up 384.94 and please report if that helped on your system too.

    (Tested with OVR service - not tested with SteamVR)
    Last edited by Sharkster-NXR; 01-24-2018, 11:53 PM.

    Leave a comment:


  • replied
    Sharkster-NVR Just read that the author of the Oculus Tray Tool is working on a new version supporting the 1.22 API. That may help with the ASW control issue. This said, ideally the whole pipeline should work out of the box, without the need of any tweaking tools.

    Leave a comment:


  • replied
    Originally posted by vr_marco View Post
    Can you hit 90 FPS constantly or do you see it varying? Do you see any difference with AWS turned on/off?
    We don't aim for 90 FPS, as we do quite demanding visualizations and real-time configruators. At that level of complexity, we cannot reach 90 FPS on an HMD although our scenes are somewhat optimized (not as optimized as e.g. a 3D shooter, but coming from the games business, we do have an understanding of optimizing scenes). Plus, we sell the complete system... hardware, software all bundled in a nice case, ready to be used "out-of-the-box".

    We can pre-configure our systems completely. The standard configuration for our PCs (notebooks) is a GTX 1070 (8 GB video RAM), current i7 CPU, 32 GB of RAM, SSD etc. Eveything that should make the VR experience as fluid and smooth as possible. Yet, even with the comfort of being able to pre-configure the entire system, Oculus doesn't allow us to e.g. permanently disable ASW (which smoothes the stuttering noticable, if turned off). With ASW on, the stuttering sometimes (maybe in 2 of 10 cases), the stuttering becomes so bad, the whole experience is simply not at all bearable.

    Now, you might think that our visualizations are simply too demanding hardware-wise, but that's not true, as they run at solid 45 FPS. Plus, with the new Oculus Home screen the stuttering and jitters are even noticable with just the Home screen open. And I'm 100% sure everything used to run a whole lot smoother, when we first decided to use Oculus Rift for our systems. Even if the current issues may probably not be Oculus' fault alone (as there might be multiple sources such as NVidia or Windows), I fail to understand, how I cannot configure my hardware according to MY preferences (ASW off). That's just insanely arrogant or at least ignorant of Oculus.


    Originally posted by btengelh View Post
    Is your Windows 10 Game bar disabled? I've seen several reports of it costing a lot of performance. Here's how to turn it off: https://www.howtogeek.com/273180/how...-and-game-bar/
    Did you try a clean install? If it's not UE4 relatd, maybe something else. Disable all virus scanners, background services, etc.?
    I will try and disable the "game bar", although I believe that the expensive part of the game mode, game bar etc. ist the optional DVR recording. And that's already turned off on our systems (as it's off by default). But thanks for your reply. I'm always interested in new things to try out.

    The systems are by definition "clean installs", as these are PCs we're going to sell with our content. They carry only Windows, Oculus and UE stuff. No other games, tools, system hacks... nothing.



    Originally posted by vr_marco View Post
    Maybe we should move this discussion back to the Oculus forum and raise our voices.


    I will do some more research today and then probably open a comprehensive thread on their forum. Also opening a support ticket with a reference to that and this thread (and the multiple other threads on the web where people moan about issues like this... The web is full of it. And also full of the usual recomendations... that I've all tried - no fix in sight). It's kinda funny how Oculus invests money in developing a new colorful Home screen, when you can't even enjoy it jitter-free. :/

    Leave a comment:


  • replied
    Originally posted by btengelh View Post
    Is your Windows 10 Game bar disabled? I've seen several reports of it costing a lot of performance. Here's how to turn it off: https://www.howtogeek.com/273180/how...-and-game-bar/
    Did you try a clean install? If it's not UE4 relatd, maybe something else. Disable all virus scanners, background services, etc.?
    Optimizations can surely be done on development computers, but the point is that it should ultimately work well on regular user's computers, to whom you cannot ask to uninstall standard applications/features just to make your own product work as expected.

    Leave a comment:


  • replied
    Is your Windows 10 Game bar disabled? I've seen several reports of it costing a lot of performance. Here's how to turn it off: https://www.howtogeek.com/273180/how...-and-game-bar/
    Did you try a clean install? If it's not UE4 relatd, maybe something else. Disable all virus scanners, background services, etc.?

    Leave a comment:


  • replied
    Originally posted by Sharkster-NVR View Post
    The whole Oculus experience is just a pain in the ***... They even removed the windows registry keys that once allowed you to permanently disable ASW.
    Thanks for sharing your findings! Can you check one thing? With the Oculus performance HUD shown, when the stuttering happens, do you see frames being dropped and a downward spike in the Performance Headroom. Can you hit 90 FPS constantly or do you see it varying? Do you see any difference with AWS turned on/off?

    Maybe we should move this discussion back to the Oculus forum and raise our voices.

    Leave a comment:


  • replied
    After doing some more tests with multipls rifts, various sensors and PCs, I'm now very sure that the problem is NOT UE related. You can reproduce the jitter and stuttering on older engine builds (pre 4.16). So, it must've sneaked in with a Windows, Oculus or maybe NVidia update... or maybe caused by more than one source.

    The stuttering gets worse the more complex a scene is. ASW set to on also increases the negative effect. On a sidenote: I can't turn off ASW permanently. If I set it to off via the debug tool, it resets to "AUTO" every time I start OVR servce. If I use the Oculus Tray Tool (OTT) with auto-start on Windows launch, the OTT starts first, then the OVR service, resetting the ASW to auto again. Only chance to disable ASW for good is to launch the Debug Tool, AFTER I've started OVR service, disable it and THEN launch our VR app.

    The whole Oculus experience is just a pain in the ***... They even removed the windows registry keys that once allowed you to permanently disable ASW.

    Leave a comment:


  • replied
    Originally posted by vr_marco View Post
    I have noted good stability improvements with 4.18.2/4.18.3, NVidia drivers 388.59 and CPU overclocking turned OFF. 4.17.x still crashes like crazy.
    4.18.2 didn't do anything for us, but it's not about crashes anyway, but about significant post 4.16 performance drops, stuttering, tracking issues etc.

    We have three Oculus Rift in use on multiple high-end rigs. So it's most likely NOT hardware related. It may, however, be related to Windows updates, NVidia etc. - The point about sudden stuttering and performance loss started in Q3/Q4 2017 and there are multiple threads on the Oculus and Unreal forums regarding that subject. Yet, neither forum came with a reply from officials. Zero response. Just like on this thread.


    Originally posted by btengelh View Post
    If you have critical questions for serious projects, answerhub is your way to go
    Yea, I guess you're right and I will do that. I was just surprised that there are so many people reporting issues very similiar to what we experience, yet there's so few (i.e. none) official response on the boards. We're running our business on this... and it's very hard if you have to deal with issues that are totally out of your control or don't even get acknowledged. Anyway... thanks for your tip!
    Last edited by Sharkster-NXR; 01-22-2018, 06:01 PM.

    Leave a comment:


  • replied
    Originally posted by Sharkster-NVR View Post
    How are we supposed to use UE4 for serious projects, if critical questions and reports are ignored for so many months?
    If you have critical questions for serious projects, answerhub is your way to go

    Leave a comment:


  • replied
    Originally posted by Sharkster-NVR View Post
    How are we supposed to use UE4 for serious projects, if critical questions and reports are ignored for so many months?
    I have noted good stability improvements with 4.18.2/4.18.3, NVidia drivers 388.59 and CPU overclocking turned OFF. 4.17.x still crashes like crazy.

    Leave a comment:


  • replied
    So, this thread is three pages long now. Starting in Summer 2017 (!), there still NO official word from Epic about the reported issues. How's that even possible? Shouldn't anyone at Epic read this and go "Uhmm... there seems to be a problem if so many peeps are complaining for months." - Ignoring the subject doesn't help us devs nor our clients who moan about the performance, stuttering etc. We can't even give them an ETA for a fix. In fact, the problems weren't even acknowledged.

    How are we supposed to use UE4 for serious projects, if critical questions and reports are ignored for so many months?

    Leave a comment:


  • replied
    UPDATE: I narrowed down some of my GPU crashes on the ASUS development laptop to the presence of the SkypeHost.exe process running in the background. Once this process has been terminated (after which I uninstalled Skype/Messaging through the PowerConsole) I don't get any longer crashes/BSOD. Will keep monitoring and report back.
    Last edited by vr_marco; 01-03-2018, 11:17 AM.

    Leave a comment:

Working...
X