Announcement

Collapse
No announcement yet.

General bad Oculus Rift performance in Unreal Engine 4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    driving me nuts. Have the same issues. Weird thing is that I run a titan black, and the fps is still high. But I got this ghosting.
    Any option needs to be setup in the project to get rid of this lantency?

    Thanks.

    Comment


      #17
      set "motion" to 0.0 in the postprocess and make sure Low persistence its ON 'hmd lp'
      pd: excuse my english.

      lfw/paid modeling, painting, texturing.

      Comment


        #18
        UE4 4.4.2 and SDK 0.4.1 here.

        HMD SP 100 boosts my frame rate up to 120fps from 60-75fps but is freezes my Rift. It becomes unresponsive.

        The feed fluctuates from 65-75fps on the DK2 on a GTX680 (2GB) card on the Realistic Rendering demo scene.

        This new portrait rotation spec for the DK2 screen and vertical tearing is killing developers trying to push FPS limits on next gen development. The DK1 could at least stand to drop to 40-50fps and it was bearable. 65-74fps and it's excruciating on the DK2!!

        EDIT:

        "HMD TIMEWARP" solved my judder, now butter smooth synced 75fps

        HMD SP 100 still freezes my DK2 screen.
        Last edited by 8Infinite8; 09-10-2014, 10:38 PM.
        _________________________________________________
        I N F I N I T E
        www.ir-ltd.net
        www.triplegangers.com

        Comment


          #19
          Originally posted by 8Infinite8 View Post
          This new portrait rotation spec for the DK2 screen and vertical tearing is killing developers trying to push FPS limits on next gen development. The DK1 could at least stand to drop to 40-50fps and it was bearable. 65-74fps and it's excruciating on the DK2!!
          I've been using Direct Mode, and by using alt+enter on an unreal game, I'm able to get 100fps+. GTX 770. I don't know if using extended desktop mode is still recommended.

          Comment


            #20
            Thanks. This is Direct Mode.

            HMD SP 100 would solve the problem apart from this Rift freezing bug.
            _________________________________________________
            I N F I N I T E
            www.ir-ltd.net
            www.triplegangers.com

            Comment


              #21
              Originally posted by 8Infinite8 View Post
              Thanks. This is Direct Mode.

              HMD SP 100 would solve the problem apart from this Rift freezing bug.
              Have you tried restarting the rift? Once I change HMD I have to restart it to make it work, that or not run it in direct HMD mode, which also gives me better FPS for some reason.

              Comment


                #22
                Ok i'll repost a mix of tips i learned from aussieburger, spyro and others in case some people missed them:


                - In order to have good performance while developing (without having to close the editor):

                1. Editor Preferences -> Miscellaneous -> Performance -> Tick "Use Less CPU when in Background"
                2. When launching the app, press the little Arrow next to Play and select "Standalone Game"
                3. While the game is loading Minimize the UE4 editor
                4. Once the game has loaded in it's window press Alt+Enter

                At least on my machine i get exactly the same fps as running the game from outside the editor or packaged.


                - If using Direct Mode, disable mirroring to gain A LOT of performance back (about 20 fps more for me)!

                1. Launch game
                2. Bring up the console
                3. Type "hmd mirror off"

                (you can also set this via Blueprints)


                - If using Direct Mode, setting Screen Percentage (hmd sp) manually while in-game freezes the App, BUT it does work if you set it via a Blueprints:

                Use "Execute Console Command" (hmd sp XXX) after "Event Begin Play".


                - Direct Mode (without mirroring) seems to have less latency and about 15 fps better performance for me than Extended mode.

                R9-290, using the "VR First Person Template" in Direct Mode, with "Shadow Quality=2", "Anti-Aliasing=6" and "Screen Percentage=160" (rendering internally at 3072 x 1728), i get between 80 and 100 fps (locked at 75 with vsync on).


                Have fun!
                Last edited by PatimPatam; 09-11-2014, 01:19 PM.

                Comment


                  #23
                  Originally posted by PatimPatam View Post
                  Ok i'll repost a mix of tips i learned from aussieburger, spyro and others in case some people missed them:


                  - In order to have good performance while developing (without having to close the editor):

                  1. Editor Preferences -> Miscellaneous -> Performance -> Tick "Use Less CPU when in Background"
                  2. When launching the app, press the little Arrow next to Play and select "Standalone Game"
                  3. While the game is loading Minimize the UE4 editor
                  4. Once the game has loaded in it's window press Alt+Enter

                  At least on my machine i get exactly the same fps as running the game from outside the editor or packaged.


                  - If using Direct Mode, disable mirroring to gain A LOT of performance back (about 20 fps more for me)!

                  1. Launch game
                  2. Bring up the console
                  3. Type "hmd mirror off"

                  (you can also set this via Blueprints)


                  - If using Direct Mode, setting Screen Percentage (hmd sp) manually while in-game freezes the App, BUT it does work if you set it via a Blueprints:

                  Use "Execute Console Command" (hmd sp XXX) after "Event Begin Play".


                  - Direct Mode (without mirroring) seems to have less latency and about 15 fps better performance for me than Extended mode.

                  R9-290, using the "VR First Person Template" in Direct Mode, with "Shadow Quality=2", "Anti-Aliasing=6" and "Screen Percentage=160" (rendering internally at 3072 x 1728), i get between 80 and 100 fps (locked at 75 with vsync on).


                  Have fun!
                  Thanks very much for the break down, most appreciated. I've tried all that apart from the blue prints tip. Not sure how to do this "Use "Execute Console Command" (hmd sp XXX) after "Event Begin Play"."

                  Being able to set the screen percentage will surely solve the low FPS problem. If I can some how set hmd sp xxx
                  _________________________________________________
                  I N F I N I T E
                  www.ir-ltd.net
                  www.triplegangers.com

                  Comment


                    #24
                    Originally posted by Kuro1n View Post
                    Have you tried restarting the rift? Once I change HMD I have to restart it to make it work, that or not run it in direct HMD mode, which also gives me better FPS for some reason.
                    I don't think I can restart the Rift and expect UE4 to pick it up again in Direct Mode. If I run in Extend I get low FPS.
                    _________________________________________________
                    I N F I N I T E
                    www.ir-ltd.net
                    www.triplegangers.com

                    Comment


                      #25
                      It can be restarted and 'picked up' again while the editor is running (and oculus runtime is in direct mode) I've done it a few times to get positional tracking back. You need to restart it in the config and turn it off/on from the rift power button and it should be fine.

                      Also to do the bit you are unclear about...

                      in your level blueprint - add the node 'event begin play' (type that into the box and it will show) then add another node 'execute console command' - join them up and add the text "hmd sp XXX" in the box of the node you just added.

                      I have a number of these in sequence to put me instantly into full screen (to rift) no messing needed. You won't need all these and can remove/add whatever you like but this should steer you in the right direction!

                      Click image for larger version

Name:	bpstart.jpg
Views:	1
Size:	187.7 KB
ID:	1056631
                      Attached Files
                      Last edited by Sharpfish; 09-15-2014, 06:18 PM.

                      Comment


                        #26
                        Originally posted by Sharpfish View Post
                        It can be restarted and 'picked up' again while the editor is running (and oculus runtime is in direct mode) I've done it a few times to get positional tracking back.

                        Also to do the bit you are unclear about...

                        in your level blueprint - add the node 'event begin play' (type that into the box and it will show) then add another node 'execute console command' - join them up and add the text "hmd sp XXX" in the box of the node you just added.

                        I have a number of these in sequence to put me instantly into full screen (to rift) no messing needed. You won't need all these and can remove/add whatever you like but this should steer you in the right direction!

                        [ATTACH=CONFIG]11513[/ATTACH]
                        You just saved me.... THANK YOU!

                        Comment


                          #27
                          MANY thanks. I will try this tonight!
                          _________________________________________________
                          I N F I N I T E
                          www.ir-ltd.net
                          www.triplegangers.com

                          Comment


                            #28
                            You can also disable and then re-enable stereo either by using "stereo off/on" or simply by pressing Alt+Enter to enable/disable full screen to unfreeze the screen after a screen percentage change.

                            Comment


                              #29
                              THANKS, specially to Sharpfish and Atsk !!!

                              Comment


                                #30
                                Originally posted by AtsK View Post
                                You can also disable and then re-enable stereo either by using "stereo off/on" or simply by pressing Alt+Enter to enable/disable full screen to unfreeze the screen after a screen percentage change.
                                When you press alt+enter twice, the resolution changes. For example, after I do so, r.SetRes returns 1366x768 (my monitor's native resolution). Made a thread about it here: https://forums.unrealengine.com/show...en-rift-screen
                                [VR Demo] Crystal Coaster (Oculus forums)

                                Comment

                                Working...
                                X