Announcement

Collapse
No announcement yet.

Stable 4.14 shiping build for Daydream crashes under 4.15,4.15.1 and beta 4.16

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Daydream] Stable 4.14 shiping build for Daydream crashes under 4.15,4.15.1 and beta 4.16

    I am pretty frustrated that I am not able to create a build of my modified shipping (available in Google Play Store as a FREE tech Alpha preview only) Daydream SunTemple build on 4.14 and get it to run correctly on my Pixel XL with Android version 7.1.2, with latest Google VR and Daydream. Any build besides the shipping build, crashes even though all successfully build. I have also noticed your GVR Plugin only uses 1.2/GVR NDK v1.10.0 (when GVR NDK v1.4 is the latest), NDK 12.b (even though the latest is r14.b), and using Android SDK Tools 25.2.5 since 24.x.x don't exist anymore.

    Since Android 7.1.2 is the default stable build on the Pixel and most Pixels are now updated to this, when can we see the latest updates for the plug-in and Android libraries? It should also be noted that even though I select ONLY OpenGL ES3.1, my log shows only [arm64-es2] which has been the case since 4.14 even though 4.13 did allow for ES3.1.

    My end goal is to get stable build with the new MSAA forward rendering, then optimize textures & materials further, as well reduce the external foliage and effects to reduce mesh and texture memory for the beta build, but have not been able to do this for three months.

    Here is the Google Play Store link, which is Daydream controller active allowing you move based upon sliding your thumb across the touchpad. After I get the framerate up, I plan to add gyro control to allow you to turn without having to move your head. The end goal is to use this Daydream controller technique for 'Segway' type object and hands for other projects I am working on.

    https://play.google.com/store/apps/d...untemplevulkan (As you can see my ultimate goal is to use Vulkan).

    #2
    4.16 will update to GVR NDK v1.40.0. The preview of 4.16 is expected soon.

    GoogleVR is certainly under active development and there are fixes in 4.15 and 4.16.

    I personally ran google vr on pixel with UE4 4.15, and Android API 24 (sdk support library 23.2.1) I believe we distribute a version of codeworks that includes that.

    Comment


      #3
      Do you have any information about how it is crashing? A log or callstack?

      Comment

      Working...
      X