Announcement

Collapse
No announcement yet.

Oculus Rift DK2 and UE4 4.3: problems with Oculus Runtime 0.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Originally posted by Gnometech View Post
    v0.4.1 of the Oculus SDK/Runtime has just been released, and in the email it was stated:

    "UE4 integration patch is now available that supports 0.4 SDK and runtime"

    Where might this patch be? It wasn't part of the Oculus SDK.

    - Dave
    You'd need to get it from the Oculus fork on Github and build it yourself: https://github.com/Oculus-VR/UnrealEngine/tree/4.3

    Comment


      #62
      Originally posted by The Other Abbott View Post
      . I set World Settings > Lightmass > Num Indirect Lighting Bounces from 7 to 4 or 1 or 0 and the quality and smoothness and it seems to improve overall fps.
      This should have no impact on your framerate. This setting will only help decrease your Lightmass light baking time (it tells Lightmass how many times the light should bounce around your scene). Visually - the difference between 1 and 7 should be significant - so I suggest rolling this setting back to 7 so that you get all of that nice bounced light back in your scene since it's essentially free.

      -Chris
      Chris Horne
      #unrealengine: VerseVR|Chris
      www.versevr.com
      www.twitter.com/distastee

      Comment


        #63
        Ok I suppose that makes sense. Not sure but it seems like it improved 5-10 fps and I had less jutter but then again its possible that was something else like the editor was open or something in previous tests.

        Comment


          #64
          I tried v0.4.1 oculus SDK/Runtime with unreal engine 4.3.1 , but I cannot get it to work.. ****

          Anyone has unreal engine working WITHOUT the whole github stuff...

          Maybe I'll just wait a week or two and hope it will fix itself

          Comment


            #65
            At the moment recompiling UE4 4.3.1 with Oculus 4.3 branch on Github is the only way to get a workable solution. UE4 4.4 has some issues with the current 0.4.1. I am looking forward to see an integration of the latest UE4 4.4 with the latest Oculus SDK in the near future. Recompiling isn't that painful but it is a nuisance.

            Comment


              #66
              Good news everyone! We have a fix on the way for Oculus 0.4.1 that will be integrating the ThirdParty 0.4.1 libs and headers and removing the old ones. Stay tuned to the announcements.
              Twitch /unrealalexander| Twitter @UnrealAlexander
              How to report a bug? | Installation & Setup issues?
              Call me to a thread by posting this: [MENTION]Alexander Paschall[/MENTION]

              Comment


                #67
                Originally posted by Alexander Paschall View Post
                Good news everyone! We have a fix on the way for Oculus 0.4.1 that will be integrating the ThirdParty 0.4.1 libs and headers and removing the old ones. Stay tuned to the announcements.
                Yes it is very good news!

                and usual question in such situation:

                ... when?

                Comment


                  #68
                  that is worth a usual answer:

                  ...when its ready
                  pd: excuse my english.

                  lfw/paid modeling, painting, texturing.

                  Comment


                    #69
                    4.41 preview is actually up.

                    https://forums.unrealengine.com/show...Hotfix-Preview!

                    Comment


                      #70
                      Thank you for sharing a link
                      thoi trang - dich vu seo gia re - thiet ke web ban hang chuyen nghiep/ thiết kế web chuyên nghiệp webicovn / thiết kế web bán hàng gia re

                      Comment


                        #71
                        Originally posted by DIO_666 View Post
                        What I don´t understand is, why there is only stuttering when turing your head.
                        When I move the character forwand and backward or strafe sideways there is almost no stuttering?
                        That fact drove me crazy as well. I was sure that it wasn't a regular framerate problem.
                        I don't know if this was already posted, but I finally found the solution to this strange stuttering during head rotations: go to your project settings and deactivate "smooth frame rate". It's under general settings.

                        In my case this solved the problem and now everything is smooth as silk.

                        Edit:

                        Sadly I got the same stuttering AGAIN. I didn't change any settings since last time when it worked. It seems to be totally random. Sometimes I got no rotation-stuttering at all. This is driving me crazy...
                        Last edited by MrBungle; 08-29-2014, 09:13 PM.

                        Comment


                          #72
                          Originally posted by MrBungle View Post
                          That fact drove me crazy as well. I was sure that it wasn't a regular framerate problem.
                          I don't know if this was already posted, but I finally found the solution to this strange stuttering during head rotations: go to your project settings and deactivate "smooth frame rate". It's under general settings.

                          In my case this solved the problem and now everything is smooth as silk.

                          Edit:

                          Sadly I got the same stuttering AGAIN. I didn't change any settings since last time when it worked. It seems to be totally random. Sometimes I got no rotation-stuttering at all. This is driving me crazy...
                          Did,you check the frame rate? You can enter "stat fps" in the console to see it while in the Rift. IMO the stuttering just comes from <75 fps. This only really becomes a problem when moving the head, other movments don't seem to be affected by it much.

                          If you get <75 fps, try "sg.PostProcessQuality = 0" in the console which seems to be the biggest offender for me. Try the other stuff under sg too.

                          Comment


                            #73
                            Originally posted by Gigantoad View Post
                            Did,you check the frame rate? You can enter "stat fps" in the console to see it while in the Rift. IMO the stuttering just comes from <75 fps. This only really becomes a problem when moving the head, other movments don't seem to be affected by it much.

                            If you get <75 fps, try "sg.PostProcessQuality = 0" in the console which seems to be the biggest offender for me. Try the other stuff under sg too.
                            Thanks Gigantoad.
                            I checked the framerate in two test-projects. One of them is just the starter map from the 1st person template, the other one is a piece of terrain with a starter material applied. The first one gave me around 68-72, the second one around 65-70. After I switched off all the sg-settings, it didn't give me a noticable boost in fps, since the scene is almost empty anyway.

                            Do you really think the framerate causes the (quite extreme) stuttering? I swear that I had the very same test-levels running without stuttering sometimes when I was playing with the DefaultEngine entries from the ue4 wiki. But now I don't seem to be able to reproduce it...

                            I am almost sure that it has something to do with how it is displayed on the rift. I.e. some experiences run perfect for me in extended-mode, and stutter in directToRift-mode. In general I can run all the experiences out there just fine. That makes me think that it is not just a regular performance problem. However changing between "pauseService", "extended" and directToRift doesn't seem to change much with ue4 (exept for the fact that the direct mode is deadly slow because of the mirroring)

                            I have a I74770k @ 4ghz, a gtx780 and 16gb ram @ 2666 mhz. And I am running ue4.4.1

                            I will try to oc my gpu now but I'd be grateful for any further ideas ;-)

                            Comment


                              #74
                              disable postprocess not give me more FPS, sometimes less, you can disable some options for get better performance but not disable all.
                              pd: excuse my english.

                              lfw/paid modeling, painting, texturing.

                              Comment


                                #75
                                Hm, Gigantoad really seems to be right. I overclocked my gpu and reached the 75 cap at all times in my two test projects. The stuttering is gone. But that would mean that even slightly dropping below 75 frames makes the game almost unplayable. Or is this somehow related to the rift being set to 75 herz?

                                Anyway... my problem seems to be solved - somewhat. The fact that we are talking about an almost empty scene here is kind of frightening :-/

                                Comment

                                Working...
                                X