Announcement

Collapse
No announcement yet.

Imported Environment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [VIVE] Imported Environment

    Hi,
    So I'm modelling my environment in Maya and importing into unreal so you can walk around in VR.
    I'm currently importing a box that will get textured to act as the floor. However I can't get VR working so I can walk on it. It's a very simple task but I can't find the solution anywhere.
    Is anyone here able to help.
    I just want to be able to walk around on my imported meshes
    Jon

    #2
    Perhaps you need to set the collision in the details panel?

    Comment


      #3
      Hi, Just got your post.
      So I've got an object which I have no idea how I can walk on. and one I can't. when I look at the collision in the details panel they are exactly the same settings.

      Comment


        #4
        If you could elaborate what do you mean by walking on it ? Do you want to be able to teleport with VR template ? If so place a nav volume onto the level.
        VR/AR Development [Portfolio | YouTube | LinkedIn]

        Comment


          #5
          Hi, to make things easier I made a video so you can see
          https://youtu.be/8qJ_EZ-cVEA

          So Somehow it is working on some meshes, no idea how I did that. I recently imported a new mesh but i'm unable to teleport onto it. I've started with the template.
          On another map I've got an environment that i'm walking around on but I can't go up to any second storeys, and yes the navmesh is set high enough. If anyone knows a solution I'll really appreciate it.

          Comment


            #6
            Originally posted by JoPo815 View Post
            Hi, to make things easier I made a video so you can see
            https://youtu.be/8qJ_EZ-cVEA

            So Somehow it is working on some meshes, no idea how I did that. I recently imported a new mesh but i'm unable to teleport onto it. I've started with the template.
            On another map I've got an environment that i'm walking around on but I can't go up to any second storeys, and yes the navmesh is set high enough. If anyone knows a solution I'll really appreciate it.
            The reason you can't teleport is simply because your nav mesh doesn't cover the area you want to teleport to. You will be able to teleport onto any surface as long as that green plane will be covering your ground. You can either check the details panel for RecastNamMesh-Default and/or your NavModifierVolumes and mess with the settings there to get as much coverage as you can.

            Click image for larger version

Name:	ref.png
Views:	1
Size:	547.3 KB
ID:	1124690
            VR/AR Development [Portfolio | YouTube | LinkedIn]

            Comment


              #7
              Hi, thanks for the quick response. My NavMeshBoundsVolume is covering the entire area in the video. I've dulpicated the meshes that do work so you can see it's not the NavMeshBounds
              Click image for larger version

Name:	2017-03-14.png
Views:	1
Size:	708.2 KB
ID:	1124692

              Comment


                #8
                Trust me, it's nav mesh volume. First look how high above the actual ground mesh your volume gets projected, second it only covers bits of the ground. If you'd press the track pad and move around your controller with track pad pressed around the ground your teleport arc would "catch" the nav mesh for a second. That being said, you can only teleport to the surface which is covered by nav mesh volume, whole teleport logic is based on that.

                Look at the screenshot below and see how nav mesh should be placed to get most out of teleport logic from default VR template.

                Click image for larger version

Name:	ref2.jpg
Views:	1
Size:	724.1 KB
ID:	1124693
                VR/AR Development [Portfolio | YouTube | LinkedIn]

                Comment


                  #9
                  I've re-opened my scene to find it's working. Any chance it's got something to do with a saving thing?

                  Comment


                    #10
                    Ok, I started deleting the objects I didn't want and now I've lost the whole green area.
                    I really do appreciate your help but it's really annoying how i can't just import a floor and be able to teleport on it.

                    Comment


                      #11
                      Place your floor meshes onto the level, place your nav mesh volume, big enough to cover everything, set collisions on your meshes to Block All, play with nav mesh settings (both volume and RecastNavMesh). I can see you are hesitant to actually change the default values of the nav mesh. You'll get it working once the floor in your level is covered with green.

                      That's all there is to it, unless you haven't modified default VR Pawn it has to be working.
                      VR/AR Development [Portfolio | YouTube | LinkedIn]

                      Comment


                        #12
                        I tried that but I was still having trouble. I kinda cheated a bit and kept the default floor from the template in to get my floors to work. But thank you for the help I really appreciate it.
                        I'm currently stuck on another problem if you've got time to look at it.
                        https://forums.unrealengine.com/show...ger-Play-Audio

                        Comment

                        Working...
                        X