Announcement

Collapse
No announcement yet.

"Is Head Mounted Display Enabled" triggering True in Packaged Games

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Is Head Mounted Display Enabled" triggering True in Packaged Games

    Hello. When I use "Is Head Mounted Display Enabled" in editor or through play, it works perfect.. If in VR mode, it loads my VR stuff, if not in VR preview and the headset is not in use, it loads non VR stuff.

    However it functions differently when packaged. I think it's detecting my headset regardless of whether or not I have it on or am using the -vr target parameter to force VR.. and thus it's always loading my VR stuff, even when I want non VR mode. This makes it impossible for me to test non VR without unplugging my HMD, which isn't realistic, and kind of defeats the entire point of the "is Head Mounted Display enabled node"

    Am I missing something or doing something wrong? is there a work around?

    Ideally I'd have the VR shortcut and the non VR shortcut and that node would work.

    #2
    Anyone else having this issue?

    4.15 introduced a new node "Is Head Mounted Display Connected" to work alongside "Enabled" which made me think the issue was fixed.. but no. The command properly works in stand-alone mode, it works in all forms of editor play testing.. but when packaged, It always registers as enabled.

    I even had my friend make C++ code that checks if the HMD is enabled AND the game is in stereo mode even THAT registers true, even though it's not! Again, works great in editor or stand alone mode.

    Edit: even with the oculus runtimes disabled so it's not detected, it registers as true :|
    Last edited by Pinworm; 02-23-2017, 11:42 PM.

    Comment


      #3
      Weird. It always turned false in my packaged projects in 4.14. Thats why I had to put Get HMD Name and if its equal to SteamVR, load VR stuff. I didnt test 4.15 yet.

      Comment

      Working...
      X