Announcement

Collapse
No announcement yet.

Disable Sensor Unit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [OCULUS] Disable Sensor Unit

    Hi guys,

    for a VR project we need to disable the sensor unit of the rift cv1. Unfortunately we get an oculus critical error (on home screen) that says we need to acctivate the sensor. We don't want the sensor. Is there a way to get around this? Unplugging seems to not help.

    Thank you!

    #2
    Do you need it to be disabled, or is it enough to ignore the positional movement based on it? Any tracking?

    Comment


      #3
      We do not have any tracking. We would only need the rotational values of the oculus. And you're right, we need to somehow disable the positional movement. I found something on a tutorial, but the node seem to not exist anymore. It was via camera manager and then set "Follow HMD Orientation". I don't know if this would do the trick.

      Comment


        #4
        Originally posted by MErbrich View Post
        We do not have any tracking. We would only need the rotational values of the oculus. And you're right, we need to somehow disable the positional movement. I found something on a tutorial, but the node seem to not exist anymore. It was via camera manager and then set "Follow HMD Orientation". I don't know if this would do the trick.
        Why don't you just turn your sensor around so it can't see the headset?
        UE4 VR Cookbook
        Mitch's VR Lab tutorial series
        VR Content Examples

        Comment


          #5
          Yes that's indeed an option. We would prefer to not use it at all though.
          We're also getting strange movement of our player character when moving the head forward and backward. The player moves with the head motion....

          Comment


            #6
            Disabling the sensor doesn't sound like a good idea. The main motion tracking for the Oculus takes place inside the head-set, in its Inertial Measurement Unit, the constellation sensor just complements and corrects it. Even if you manage to disable/rotate away the sensor all you will get is a very bad tracking of the HMD with the consequent warning/error from the Oculus software.

            What you would rather need to do is prevent any unwanted rotation (e.g. pitch rotation) of the HMD from being applied to your camera inside UE4. What follows is from the top of my head because I cannot test it right now.

            - First uncheck the Follow HMD rotation for your VR Pawn.
            - Then inside your VR Pawn Blueprint use Get Orientation and Position to get the orientation/position of the HMD.
            - From it extract only the Yaw rotation and apply it to the VR Pawn camera via AddRelativeRotation. This step may be different depending on how your VR Pawn is setup.

            Give it a try and see if it works. I will test it myself as soon as I have the chance.

            Cheers,
            Marco.
            CTO | Head of VR Development - Visit us at http://humanxr.com
            My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

            Comment


              #7
              Originally posted by vr_marco View Post
              Disabling the sensor doesn't sound like a good idea. The main motion tracking for the Oculus takes place inside the head-set, in its Inertial Measurement Unit, the constellation sensor just complements and corrects it. Even if you manage to disable/rotate away the sensor all you will get is a very bad tracking of the HMD with the consequent warning/error from the Oculus software.

              What you would rather need to do is prevent any unwanted rotation (e.g. pitch rotation) of the HMD from being applied to your camera inside UE4. What follows is from the top of my head because I cannot test it right now.

              - First uncheck the Follow HMD rotation for your VR Pawn.
              - Then inside your VR Pawn Blueprint use Get Orientation and Position to get the orientation/position of the HMD.
              - From it extract only the Yaw rotation and apply it to the VR Pawn camera via AddRelativeRotation. This step may be different depending on how your VR Pawn is setup.

              Give it a try and see if it works. I will test it myself as soon as I have the chance.

              Cheers,
              Marco.
              Unchecking FollowHMD removes the lateupdates so the view won't be 1:1, also Yaw is mixed and will never be perfect with that method.

              You can keep it on follow HMD and reposition the camera in a later tick than the camera uses instead so it overrides the relative movement.

              That being said locking the head to a single place in space will always feel weird.


              Consider supporting me on patreon

              My Open source tools and plugins
              Advanced Sessions Plugin
              VR Expansion Plugin

              Comment


                #8
                Hi Mordentral,
                can you please explain a bit better what you mean by "the view won't be 1:1, also Yaw is mixed and will never be perfect". I agree on the fact that locking the HMD camera in a fixed position and only allowing for Yaw rotations doesn't provide for the best VR experience, but we are just going along with the request from the OP.
                Cheers,
                Marco.
                CTO | Head of VR Development - Visit us at http://humanxr.com
                My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                Comment


                  #9
                  Originally posted by vr_marco View Post
                  Disabling the sensor doesn't sound like a good idea. The main motion tracking for the Oculus takes place inside the head-set, in its Inertial Measurement Unit, the constellation sensor just complements and corrects it. Even if you manage to disable/rotate away the sensor all you will get is a very bad tracking of the HMD with the consequent warning/error from the Oculus software.

                  What you would rather need to do is prevent any unwanted rotation (e.g. pitch rotation) of the HMD from being applied to your camera inside UE4. What follows is from the top of my head because I cannot test it right now.

                  - First uncheck the Follow HMD rotation for your VR Pawn.
                  - Then inside your VR Pawn Blueprint use Get Orientation and Position to get the orientation/position of the HMD.
                  - From it extract only the Yaw rotation and apply it to the VR Pawn camera via AddRelativeRotation. This step may be different depending on how your VR Pawn is setup.

                  Give it a try and see if it works. I will test it myself as soon as I have the chance.

                  Cheers,
                  Marco.
                  Thank you! I will try it. I know using HMD without the sensor is completely stupid but for this project we need it.

                  Comment


                    #10
                    Originally posted by MErbrich View Post
                    Thank you! I will try it. I know using HMD without the sensor is completely stupid but for this project we need it.
                    Ok I tried it. I would say, it does somehow what it should, but it is very hard to control... #motionsickness
                    I think we will have to go with just hiding the sensor away so the oculus software won't bother us. I will leave the "Follow HMD" on.
                    If you have any further ideas let me know.
                    Thank you!

                    Comment


                      #11
                      Motion sickness is bad. You don't want to trigger it.

                      Here is another idea. Can you try the suggestion in the post below? The OP is asking about the Vive, but it applies to the Oculus Rift as well.

                      https://answers.unrealengine.com/que...-location.html

                      Cheers,
                      Marco.
                      CTO | Head of VR Development - Visit us at http://humanxr.com
                      My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                      Comment


                        #12
                        I need to disable the sensors too. I'm using leap motion as controllers and zed stereocamera for motion tracking, but i only have 3 USB ports. The systems dont work with hubs, since their all kinda huge on data transfer.

                        Comment

                        Working...
                        X