Announcement

Collapse
No announcement yet.

Single/Multiplayer, Touch & Vive Proteus blueprint only Template

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Additionally, the github links for 4.21 don't appear to be working. I downloaded the master and tried to open it in 4.21, I also tells me that "Proteus" and "ProteusAvatar" "are missing or built with a different engine version" and when I try to rebuild them, it doesn't work. I also did the few coding changes to both the plugin as well as the engine itself. Is the problem on my end or yours?

    Thanks for all your hard work! It is much appreciated

    Comment


      I've made minor changes to the doc, to accomodate latest engine update:
      • Unreal Engine 4.21*, Oculus-branch, latest commit 7355b71 (Jan 30, 2019), found at https://github.com/Oculus-VR/UnrealEngine
      • Unreal 4.20: Uses Oculus Platform SDK 1.24, OVR Plugin 1.31, Audio SDK 1.18
      • Unreal 4.21: Uses Oculus Platform SDK 1.34, OVR Plugin 1.32, Audio SDK 1.34

      and

      Modification #3 (Unreal 4.21)
      Mandatory Modification to use the Proteus Avatar Plugin

      change \Engine\Source\Runtime\Engine\Classes\Components\PoseableMeshComponent.h

      Line 78 add (line after friend class UOvrAvatar

      friend class UProteusOvrAvatar;


      Comment


        meuliano I would not see any development problem. I did not try it, but you could try it by packaging one version in "debug mode", and the other for Rift or Go. It should work. However, I think the problem would be the Oculus Store policies. I don't think Oculus would allow publishing a game that you can play without an HMD. Steam would be the way to go. There was Keep Talking and Nobody Explodes and others ( https://www.roadtovr.com/oculus-anno...us-go-gear-vr/ ), but these games require an HMD as the main player. BTW your game seems very interesting, can't wait to try it!

        Comment


          meuliano Just to be sure, there's the procedure:

          1) Download the Unreal Engine .zip file from github (or sync through github app)
          2) Unzip
          3) Setup.bat
          4) GenerateProjectFiles.bat
          5) Open UE4.sln with Visual Studio
          6) Make the modifications needed to the engine, as specified in pdf document
          7) Build UE4

          8) Download the latest Proteus Template .zip from github (or sync through github app)
          9) Right-mouse click on Proteus.uproject, Switch Unreal Engine Version, for correct engine version
          10) Open Proteus.sln with Visual Studio
          11) Make changes to the ProteusOvrAvatar.cpp if using Unreal 4.21, as specified in pdf document
          12 ) Build Proteus

          13) Now ready to open Proteus.uproject

          Comment


            vbvisr
            "
            "I've found another bug in the template.
            Rift = host, Vive = client: when teleporting the room boundaries are not drawn for the Vive, only the arrow and the dot.
            Rift = client, Vive = host: no problems, room boundaries are drawn on the Rift and the Vive when teleporting.

            Does anyone have a solution for the teleportation boundaries / arrow / dot remaining on screen sometimes? These stuck teleportation boxes/arrows are only visible at the client side, not at the host."


            New version (5.0) should have fixed that; if you still use previous version you could apply the same changes, found in Authority/Remote Teleport function

            also "so im almost done and starting to package the project. everything test fine but then when i compile and load i get some frame rate issues and i cant load my level. when i first boot it up if i try to load one of the default levels it works just fine but when i try to load my level the screen fades out and i can barely see at the top of my vision failed to load session. i see in the forums were similar issues were reported but im not seeing a fix. any help would be appreciated."

            Again, version 5.0 should have fixed that. It is also possible the playerstart is near a mesh, and because I put a fade out when head collides with the right collision capsule maybe just moving the playerstart could help resolve the problem. Try also disabling the fadout function if the problem persists.

            With latest version we gained speed, especially with the playarea and teleport beam; there's still speed to gain by sending multicast on-tick functions to c++ rather than in blueprints, I'll do that in future version.

            Note also that I'll revise SteamVR functionnality this week.

            Comment


              Hello, I am on the old version of Proteus, before 5.0 came out. I am building a multiplayer VR game and I have run into a bug when I try to seamlessly travel a lobby of players to a new map. When we get to the new map the players are respawned and the first player doesn't get any hands or a head. It's like the spawn wasn't successful. The second player seems to spawn fine but they are not able to grab anything in the map. To first get the seamless travel to work I copy/pasted the BP code from the MultiGM OnPostLogin method into the HandleStartingNewPlayer method, because post login isn't called when players seamlessly travel. I guess I am wondering now, is there anything else I will need to do to properly reinitialize the player pawns when they travel to the new map? I could really use some help on this, thanks!

              Comment


                To all who get a 404 Error, trying to download the Unreal Engine from GitHub - remember to connect your GitHub Account to your Unreal Account before you click the link (Guide: https://www.unrealengine.com/en-US/ue4-on-github).


                I am a total beginner to programming (just did some courses on udemy and once I created some multiplayer maps in times of the original Unreal Tournament in the "what does this button do"-style)
                A few weeks ago I though visual studio
                is the name of a VFX/Hollywood startup somewhere around LA....
                But as I am fortunate enough to be able to invest some time, I am just looking forward to what one as me can accomplish with this ;-).
                I have a small company in Germany that sets up real life experiences for disabled persons.
                Goal is to set up small experiences that disabled people and healthy people can enjoy together in VR and being on par (like small round based board games that only need one controller).

                That being said - thousand thanks Proteus for sharing and giving us this great head start! Without projects like this (and the market…) I wouldn`t be able to dig into this at all.

                Comment


                  Somehow the project crashes on startup at around 73% with "fatal error" message.
                  I compiled the right engine version and tried to open another project and it worked. Only with this Project it crashes.
                  The crash log says nothing, it just stops at 'Compiling shaders'

                  Comment


                    im having a bit of a issue with the plugin "The following modules are missing or built with a different engine version: Proteus ProteusAvatars Would you like to rebuild them now?" the rebuild fails every time i built the oculus branch of ue4 4.21 and built the Proteus plugin. Help!

                    Comment


                      First of all - this is not to complain, but to give some insights on my experience so far!

                      I was able to build UE4.20 (e8c8be1) without errors and UE 4.21 (7355b71) with some minor errors and was able to start both versions. I also was able to build the template after having set it up to the version I wanted to use. So far the guide works, thank you!

                      I did this on two PCs (I can provide the dxdiags if wanted).

                      On one PC I have an Oculus rift attached.
                      I started the project directly and it was compiled without errors.
                      With both builds I ran into the same problem: the "VR preview" starts and a second later it closes itself. Also the location of the vr preview window changes to the top left and seems to be a bit darker then it would be normally. I tried this on the delivered "essentials map" and on new maps I created (remember: me=NOOB!). Instead of a VR Pawn, that was missing, I used the Proteus pawn on the new maps.
                      EDIT: in the MultiMap01 the vr preview works (though swarm agent does not kick off and lightning build fails -> Edit number 2: I rebuilt the unreallightmass in the UE4.sln and this fixed it).
                      I tried other projects with both UE-versions and had no issues running the vr preview.
                      Perhaps someone has an Idea what I am doing wrong?

                      The other PC has a Pimax (with DAS and Vive controller) attached. The errors while building the 4.21 version were different from the first PC (if interested, I can provide screenshots), but I was able to register and start both versions, too. In the 4.20 version I was able to start the vr preview but nothing was shown in the HMD. In the 4.21 version the vr preview button was - as expected - greyed out. I know I have to wait for the steamVR-version to be able to work with the Pimax ;-) (while I love the comfort of the Oculus, the screen res and FOV is just so much better - the first HMD I can wear for hours without pause).

                      Thanks!
                      Last edited by Turwen; 02-13-2019, 01:03 PM.

                      Comment


                        Originally posted by SenseiHaketon View Post
                        Somehow the project crashes on startup at around 73% with "fatal error" message.
                        I compiled the right engine version and tried to open another project and it worked. Only with this Project it crashes.
                        The crash log says nothing, it just stops at 'Compiling shaders'
                        Might be worth a try: while compiling go into the lower left of the content browser, click on "view options" and disable "real-time thumbnails", then go to "edit"->"editor preferences"->and remove "enable window animations" (this also prevents the menu from shaking!).
                        The engine crashed one more time for me, but next start the information was saved and the compiling went through.

                        Also start the engine first and choose the project with "browse". As I started the project by clicking on the proteus.uproject file I ran into problems, too.



                        And if someone runs into a problem where the download of the engine is not finished (some red text I do not remember, sorry) - shorten the paths of your installation folder!
                        Last edited by Turwen; 02-13-2019, 12:34 PM.

                        Comment


                          Version 5.1 - February 15, 2019

                          What's new in version 5.1
                          • Custom hand poses, both for off-line and on-line (Oculus) Avatars
                          • Both off-line and on-line hands now share the Oculus Avatars skeleton mesh
                          Compatible with the following Unreal Engine versions:
                          Unreal Engine 4.20*, Oculus-branch, latest commit e8c8be1 (Nov 14, 2018), found at https://github.com/Oculus-VR/UnrealEngine/tree/4.20
                          Unreal Engine 4.21*, Oculus-branch, latest commit 91f23fa (Feb 12, 2019), found at https://github.com/Oculus-VR/UnrealEngine

                          Click image for larger version  Name:	01.png Views:	1 Size:	169.1 KB ID:	1585226




                          Here's how to do it:
                          In Proteus Multi/Hand Poses, duplicate BlankPose actor blueprint, and make 2 copies for each pose (left and right hand)
                          I suggest to rename them left hand with even numbers, right hand with odd numbers, starting at 0. This will be also their index.
                          Inside HandPose:

                          Click image for larger version  Name:	02.jpg Views:	2 Size:	422.1 KB ID:	1585228





                          Change hand (l/r), fingers rotations, object reference (if any) to grab, object placement, object rotation. Do that for each hand.


                          You should only change these variables:
                          Click image for larger version  Name:	03.png Views:	1 Size:	46.1 KB ID:	1585229



                          Set Attached Actor Scale at the same scale as your desired attachment actor to place the pose correctly



                          When satisfied, add the poses inside the array in MainMenuPC/HandPoses. Place them in order of their index number (even-left, followed by odd-right, etc).
                          Click image for larger version  Name:	04.png Views:	1 Size:	23.3 KB ID:	1585230



                          Finally, if you created handposes without an object reference (again one for each hand), you can assign them by their index number to an input in ProteusAvatar/Inputs. As an example, we put a peace sign pose at index 12 for left, 13 for right. Don't forget to check "Custom Pose No Object". That's it.
                          Click image for larger version  Name:	05.png Views:	1 Size:	79.2 KB ID:	1585231




                          Attached Files
                          Last edited by Proteus; 02-15-2019, 04:50 PM.

                          Comment


                            Originally posted by SenseiHaketon View Post
                            Somehow the project crashes on startup at around 73% with "fatal error" message.
                            I compiled the right engine version and tried to open another project and it worked. Only with this Project it crashes.
                            The crash log says nothing, it just stops at 'Compiling shaders'
                            I was getting exactly the same. I ran it in VS2017 debugger which returned an exception with return dli.pfnCur; in delayhlp.cpp. I continued anyway and had something similar at line 205 of ProteusOvrAvatarManager.cpp. The bit of code around it didn't look too important to my untrained eye so I commented out lines 174-214, rebuilt and ran. It got past 73%, held at 95% for AGES and then loaded. No idea yet if everything actually *works* but it's loaded so that's a start.

                            Comment


                              Latest commit February 21, 2019, commit 23a7b9a
                              • Bug fixes, mainly about of replication of Grab/Release objects, and also replication in DebugMode
                              • Fixed left hand, local avatar mirroring
                              • Removed unused assets and folders
                              • Tested Oculus Platform SDK 1.35 & latest commit on Oculus github (5af0b9f, on Feb 26, 2019)

                              Comment


                                marc.isaacs SenseiHaketon I cannot tell you why you get this error. This code is not from me but from Oculus (same function is found in the Avatar plugin). However, this function is only to inform you of which asset is loaded when avatar is requested (message found in log). So yes you can remove this function, but you should also remove all references to avoid other crashes.

                                Comment

                                Working...
                                X