Announcement

Collapse
No announcement yet.

Single/Multiplayer, Touch & Vive Proteus blueprint only Template

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Anyone else having problems launching?
    Attempting to launch the proteus project results in a build failure as follows:

    ********** STAGE COMMAND STARTED **********
    ERROR: Stage Failed. Missing receipt 'Proteus.target'. Check that this target has been built.

    Edit: Apparently packaging the project will resolve this error, but this creates furthur issues which causes cooking to fail

    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogProperty: Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/Proteus_Multi/GameInfoInstance.GameInfoInstance_C:VRSettings'. Unknown structure.
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogProperty: Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/Proteus_Multi/PlayerSaveGame.PlayerSaveGame_C:S_VRSettings'. Unknown structure.

    Any ideas on how to resolve this problem?

    Edit 2: I was able to resolve this issue, the problem with packaging was fixed by opening the files mentioned in the error log, compiling and saving them.
    Last edited by THX-IOI; 06-07-2018, 09:01 AM.

    Comment


      Hello and thank you very much for this template. My master Thesis will feature this template (or at least its functionalities) therefore I'm very grateful for it. (of course I won't forget to mention the creator and the community!)

      As part of my project I wanted to build this template for iOS, and in the future integrate it with ARKit as well, to have mixed reality between the Vive and iPhone.

      Unfortunately i'm blocked at the build stage getting the following error

      LogPlayLevel: Total build time: 33,95 seconds (Local executor: 6,53 seconds)
      LogPlayLevel: Took 35,369415s to run mono, ExitCode=5
      LogPlayLevel: ERROR: Command failed (Result:5): /Users/massimobortolamei/Documents/UE_4.19/Engine/Binaries/DotNET/UnrealBuildTool.exe Proteus IOS Development -Project="/Users/massimobortolamei/Documents/Unreal Projects/ProteusTemplate-master/Proteus.uproject" "/Users/massimobortolamei/Documents/Unreal Projects/ProteusTemplate-master/Proteus.uproject" -NoUBT
      Makefiles -remoteini="/Users/massimobortolamei/Documents/Unreal Projects/ProteusTemplate-master" -skipdeploy -ini:Game:[/Script/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Disabled -noxge -nocreatestub -NoHotReload -ignorejunk. See logfile for details: 'UnrealBuildTool-2018.06.13-15.01.25.txt'
      LogPlayLevel: (see /Users/massimobortolamei/Library/Logs/Unreal Engine/LocalBuildLogs/UAT_Log.txt for full exception trace)
      LogPlayLevel: AutomationTool exiting with ExitCode=5 (5)
      LogPlayLevel: Completed Launch On Stage: Build Task, Time: 42.127934
      LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.
      PackagingResults: Error: Launch failed! Unknown Error
      ‚Äč
      I have attached the full logs

      Three months ago before updating iOS to the latest version, and with UE4.18 and Proteus 3.3 , I was at least able to package successfully on my Mackbookpro. Of course the app on iOS would just be a black screen, and i was planning to resume debugging from this point, but at least I didn't get this Unknown Error.

      As of now, Proteus 3.3 will not start anymore on UE4.18 ( i blame the iOS updates), for those interested I started a post on the Answerhub about that https://answers.unrealengine.com/que...-template.html
      Right now I'm trying my luck with UE4.19 and the latest Proteus Template, but I get this annoying error.

      Eventually, if anyone has previous experience or advise about the correct way to build this template for iOS, I would be the most grateful for it.
      My last resort is creating a new mobile project and import the core functionalities, but my knowledge about UE is at the very beginning, therefore I'm not sure if it would be just a waste of time.

      Thanks!
      Attached Files

      Comment


        Referring to my previous post, I gave up doing things on my macbook, apparently things don't work very well there. I was able to configure the remote build on it, from my main desktop, and UE4.19 with the new Proteus4 starts, compiles and packages.
        At this point I would just like to ask for some hints on how to approach the problem of running Proteus on mobile/iphone. The only thing i can see when the game starts on iphone is the "SceneCapture2D1" actor in "mainmenu" map, everything else is black. Any idea?

        Comment


          Proteus I used an early version of your template back in 2015 and it worked very well. I'm trying to build a new project and wanted to test your newest version, but I'm having some very bad lag issues. I've downloaded the latest version of the project, opened the source project, and followed all directions on the PDF for Steam connection. When I package the game, it's absolutely unplayable in terms of framerate. It is extremely choppy. Whenever I run it in the editor, however, it runs perfectly smoothly. I also noticed that the lag is a tiny bit better when steam is closed, but still unusable. My specs are:

          Windows 10
          NVIDIA GTX 980
          Intel i5 6600K
          8g RAM

          I have the latest NVIDIA drivers/Steam/Oculus software. I've attached my console output during packaging. Any ideas of what could be going on? Thanks so much.

          UPDATE: I downloaded version 3.3 and everything seems to be working perfectly. Not sure what's making the newest one run poorly.
          Attached Files
          Last edited by jessekirbs; 06-19-2018, 02:42 PM.

          Comment

          Working...
          X