Announcement

Collapse
No announcement yet.

Single/Multiplayer, Touch & Vive Proteus blueprint only Template

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by LostMyEd View Post
    Thanks Proteus for the template its great. How would i enable the left hand to also be used to give widget interaction, I would like both hands to be able interact. ?
    1) In MotionControllerBP in the RepNotify function OnRepShowDebug you can select the debug line hand there. Remove the Switch on HandEnum or plug both hands there.
    2) Also in AvatarMaster link the WidgetInteraction Function to the button/controller you want

    Comment


    • Originally posted by kjekkbart View Post

      Is the problem in networking or is it the audio? If the latter, have you seen this thread and the linked pull request? Might not be at all related, but..
      https://forums.unrealengine.com/deve...omixer-enabled
      I will investigate this further but I don't think that's the problem. Maybe exploring doing a simple plugin enabling VOIP via directIP could be the way for now.

      Comment


      • @Proteus: Any update about the Oculus Avatars replication?

        Comment


        • Hello, I've got connection problems between host and client over simple Lan. The client sees the host match and I can join, but upon clicking "Launch" the menu disappears and the Host level isn't loaded (this should happen right???). Have a Vive -PC and an Oculus-PC as participants. No matter which is host and client, the client don't load the map. Using your "Proteus Template 3_2_2_Packaged" (after I thought it's my faulty application based onto Proteus) and have the problem. Please help me, multi user VR is badly needed for my project.

          Comment


          • @Proteus

            Hi Proteus, we've seen that, once a client leaves, their hands are kept on all other clients (and server) in their last position.
            We've added the following events in AvatarMaster and MotionControllerBP assets and now the client correctly disappears once gone.

            Click image for larger version

Name:	AvatarDestruction.jpg
Views:	1
Size:	41.9 KB
ID:	1356943
            Click image for larger version

Name:	MotionControllerDestruction.jpg
Views:	1
Size:	72.3 KB
ID:	1356944

            Furthermore, I also would ask if there are any news about Oculus Avatars.
            Thanks!

            Comment


            • Hi, I'm not sure if anyone else is having this problem but I ran into a packaging issue.

              Creating and packaging a project using the newest template works fine.

              However, running the application of that packaged project yields the following error. I was wondering if anyone else ran into this problem.


              Click image for larger version

Name:	
Views:	1
Size:	4.7 KB
ID:	1357169

              Comment


              • Originally posted by VKleinMP View Post
                Hello, I've got connection problems between host and client over simple Lan. The client sees the host match and I can join, but upon clicking "Launch" the menu disappears and the Host level isn't loaded (this should happen right???). Have a Vive -PC and an Oculus-PC as participants. No matter which is host and client, the client don't load the map. Using your "Proteus Template 3_2_2_Packaged" (after I thought it's my faulty application based onto Proteus) and have the problem. Please help me, multi user VR is badly needed for my project.
                Someone please help. What could hinder the level loading? Is mixed usage of Vive and Oculus the problem? Disabled my firewall. Both PC run Windows 10, as I said even your packaged app don't load the map. Did I misunderstood something? I need help.

                Comment


                • Originally posted by Mavulus View Post
                  Hi, I'm not sure if anyone else is having this problem but I ran into a packaging issue.

                  Creating and packaging a project using the newest template works fine.

                  However, running the application of that packaged project yields the following error. I was wondering if anyone else ran into this problem.


                  Click image for larger version

Name:	
Views:	1
Size:	4.7 KB
ID:	1357169
                  Which version of UE4 are you using? You may want to add the MainMenu map in the project settings in Project->Packaging->List of maps to include in a packaged build

                  Comment


                  • Originally posted by VKleinMP View Post

                    Someone please help. What could hinder the level loading? Is mixed usage of Vive and Oculus the problem? Disabled my firewall. Both PC run Windows 10, as I said even your packaged app don't load the map. Did I misunderstood something? I need help.
                    I've manged to get 2 Vives and test it, still to no avail. Nothing happens after finding LAN-host by the client and clicking Launch. No map load whatsoever. The default 3.2.2 packaged and the default 2.2 doesn't work either.

                    Now I'm trying a quick solution with the simple "open Map?listen" and "open serveripadress" console commands. While "open Map?listen" works and loads the map, the client -side "open serveripadress" does nothing. Does Proteus somehow forbid making a server or a client this way?
                    Last edited by VKleinMP; 09-22-2017, 07:03 AM.

                    Comment


                    • Originally posted by VKleinMP View Post

                      I've manged to get 2 Vives and test it, still to no avail. Nothing happens after finding LAN-host by the client and clicking Launch. No map load whatsoever. The default 3.2.2 packaged and the default 2.2 doesn't work either.

                      Now I'm trying a quick solution with the simple "open Map?listen" and "open serveripadress" console commands. While "open Map?listen" works and loads the map, the client -side "open serveripadress" does nothing. Does Proteus somehow forbid making a server or a client this way?
                      SOLVED

                      Ok sorry for the cryout, Steam was not showing an tray-icon but was running on one of the maschines. With Steam closed it runs perfectly.

                      Comment


                      • Originally posted by xN31 View Post
                        @Proteus: Any update about the Oculus Avatars replication?
                        I will meet the Epic guys at OC4 and from there I plan to update it to the new Oculus unified plugin, sinced everything changed since 4.17

                        Comment


                        • Originally posted by VKleinMP View Post

                          SOLVED

                          Ok sorry for the cryout, Steam was not showing an tray-icon but was running on one of the maschines. With Steam closed it runs perfectly.
                          Happy to see that the problem is resolved. Usually before releasing a new update I test it extensively with at least 2 HMDs. From what I've tested, Steam has to be closed (but not necessarily SteamVR) to use LAN or direct IP. You can still use Oculus Avatars and Oculus network even if Steam is on. I've never tested it with ReVive so I don't know with that.

                          Comment


                          • Originally posted by masmil1988 View Post
                            @Proteus

                            Hi Proteus, we've seen that, once a client leaves, their hands are kept on all other clients (and server) in their last position.
                            We've added the following events in AvatarMaster and MotionControllerBP assets and now the client correctly disappears once gone.

                            Click image for larger version

Name:	AvatarDestruction.jpg
Views:	1
Size:	41.9 KB
ID:	1356943
                            Click image for larger version

Name:	MotionControllerDestruction.jpg
Views:	1
Size:	72.3 KB
ID:	1356944

                            Furthermore, I also would ask if there are any news about Oculus Avatars.
                            Thanks!
                            Thanks for that. Will put it in the next update. For the avatars, I already worked in an update for 4.15 but since 4.16 everything changed Oculus-plugin side. Will update this following meeting Oculus-Epic guys at OC4.

                            Comment

                            Working...
                            X