Announcement

Collapse
No announcement yet.

Build VR doesn't work in 4.13.2/4.14/4.14.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [VIVE] Build VR doesn't work in 4.13.2/4.14/4.14.1

    Hello,

    I tried to build my VR game this morning, but it doesn't work. The build itself works but when I run the .exe, the VR does not activate. I am not new to UE4 and VR. So I tried something.

    I did the same thing on 4 versions of the engine: 4.11 / 4.13.2 / 4.14 / 4.14.1

    I created an empty scene and I just added a blueprint which contains a camera with an auto possess player to 0. On 4.11, it works perfectly (editor and build). But on the other versions of the engine: 4.13.2 / 4.14 / 4.14.1, this works perfectly in the editor but not the build.

    Click image for larger version

Name:	UE4_Scene.JPG
Views:	1
Size:	297.3 KB
ID:	1203862
    Click image for larger version

Name:	UE4_VRPawn.JPG
Views:	1
Size:	228.1 KB
ID:	1203863

    Did I miss something ? Can it come from steamVR ?

    ps : Sorry for my english

    #2
    In your Project settings there is an option called Start in VR. Check that on and your project should start in VR. Or you could put -VR as a command line argument in the shortcut to your projects .EXE.

    Comment


      #3
      Whoo, I had not seen the "Start in VR" in the project setting. I used the command -fullscreen and it worked in 4.11. Thank you Sam Deiter, my VR Game work !

      Comment


        #4
        Originally posted by Audera View Post
        Whoo, I had not seen the "Start in VR" in the project setting. I used the command -fullscreen and it worked in 4.11. Thank you Sam Deiter, my VR Game work !
        Glad you got it sorted! Let us know if you have any more issues.

        Comment

        Working...
        X