Announcement

Collapse
No announcement yet.

LOD blending breaks immersion when teleporting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    LOD blending breaks immersion when teleporting

    Hi there, I’m working on a small VR project in which I use the UE4 VR Template. When I teleport to a certain location I can see how the LODs of my hierarchical instanced static meshes (here some cliffs) start popping in with some delay. You can see how the engine is trying to catch up with my teleportation and then blends the different LOD into each other. This probably makes sense if you are moving linear as in a normal non vr game. Is there an option to change the speed of the LOD blending so that the right LOD is immediately there after I teleported? Or any other solutions for this immersion breaker?

    Thanks a lot!
    Attached Files

    #2
    mmmh, is nobody else experiencing this problem? I thought it would be a knows issue if one uses teleportation and LODs...

    Comment


      #3
      Yeah, but it is what it is. Live with it or disable dithering so LODs just pop

      Or make your screen fade in and out of black so that transition is a s long as LOD dithering.

      Comment


        #4
        Edit: Ok, I should have made some more research before writing this post. Sorry for that. It seems like these slow LOD transitions are specific for HISM. If I use normal static mesh actors this is not a real issue when teleporting. Second problem: No LOD specific lightmaps for HISMs, which make this solution unusable for my project which has only baked lightning. So I think I just go with static mesh actors.
        [MENTION=1680]motorsep[/MENTION]: Sorry for this noob question: But where can I disable LOD dithering?

        Comment


          #5
          Originally posted by andtheand View Post
          [MENTION=1680]motorsep[/MENTION]: Sorry for this noob question: But where can I disable LOD dithering?
          No easy way. I recall there is r.foliage variable (don't recall offhand now) that disables dithering on HISMCs.

          Comment


            #6
            LOD dithering is now off by default in 4.15 btw

            Comment

            Working...
            X