Announcement

Collapse
No announcement yet.

"Set Fixed Bounds" doesn't work as it should.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Set Fixed Bounds" doesn't work as it should.

    So I made a GPU Emitter Particle System. I want to render the particles every time even when the source is not in the view like it's shown here

    Creating a GPU Sprite Emitter

    and

    Visual Effects: Lesson 07B: Creating and Using GPU Particle Simulations.

    However as you can see in the following image "Set Fixed Bounds" only creates really small Bounds.


    Click image for larger version

Name:	Set Fixed Bounds Bugg.png
Views:	1
Size:	565.6 KB
ID:	1196470



    This even happens when I use the one from the "Content Examples" which are the same as in the video.
    They already have the right bounds. But when I press "Set Fixed Bounds" its getting small as the one like in my example.

    Any Advices?

    Thanks in Advance.

    Proxos

    #2
    Did you try settting min to be a very large negative number and max to be a large positive number?
    Ryan Brucks
    Principal Technical Artist, Epic Games

    Comment


      #3
      Originally posted by RyanB View Post
      Did you try settting min to be a very large negative number and max to be a large positive number?
      Well. I could type it all in manually and the bounds would get bigger. But normally unreal is able to do this automatically as shown in the links I provided, isn't it?

      Fortunatly I was able to work around this.
      When I delete the "GPU Sprites"-module and do "Set Fixed Bounds" it sets automated, big-enough bounds. After that I set the "GPU Sprites"-module again and the bounds stay the same.
      The question is, if those are the right automated bounds? Looks like they are. In the view it works just fine. Still weird. Might be a bugg?

      Comment


        #4
        Sorry I misunderstood. I wonder if it could be another module interacting with gpu sprites causing it. Could be a bug. Have you tried removing the const acceleration and also running the fixed bounds?
        Ryan Brucks
        Principal Technical Artist, Epic Games

        Comment


          #5
          Originally posted by RyanB View Post
          Sorry I misunderstood. I wonder if it could be another module interacting with gpu sprites causing it. Could be a bug. Have you tried removing the const acceleration and also running the fixed bounds?
          Thats exactly what i thought at first as well.

          Just tried what you suggested. Sadly no difference.

          I tried it on Beams as well. There it works. Only GPU-Sprites don't work for me.

          Comment


            #6
            Hey guys, I'm having the same problem. Meanwhile, it'd be great to set the bounding box manually, but I do not know how.
            I see you have the bounding box options on the left, but I don't understand under which section that is; so I can't make 'em pop out!

            Comment


              #7
              In case someone stumbles upon this and needs this info (like I did):
              You can see the ParticleSystem details (bounding box options included) if you click within the Emitters tab/window but not on an emitter but into the black void where there are no emitters.
              One hell of a weird way to access the actor properties...

              Comment


                #8
                Originally posted by Kokuyouseki View Post
                In case someone stumbles upon this and needs this info (like I did):
                You can see the ParticleSystem details (bounding box options included) if you click within the Emitters tab/window but not on an emitter but into the black void where there are no emitters.
                One hell of a weird way to access the actor properties...
                Thank you. This is handled really badly by UE4. Fixed bounds keeps being set wrongly, especially if in GPU mode. Seems to be very timeline-sensitive, the results vary widely based on which frame you calculate bounds on.. which is insane, because we cannot pause the sim to tell Unreal which frame to use as reference.

                Comment

                Working...
                X