Announcement

Collapse
No announcement yet.

No ambient occlusion in VR!? (Virtual reality teplate project)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    No ambient occlusion in VR!? (Virtual reality teplate project)

    So I have no visible ambient occlusion in projects created with the Virtual Reality template.
    My screen is completely white in buffer visualization (Ambient occlusion).

    I tried:
    - adding post processing volumes with the ambient occlusion cranked up
    - going to project settings -> rendering -> enabled ambient occlusion & ambient occlusion static fraction
    - export project setting from another project with AO working (for example the First person shooter template) and importing it into my virtual reality project
    - baking my light with and without light reflection capture (which shouldn't make a difference, but who knows)

    Also I'm using version 4.13.1 and I have the same problem on different PC's in different projects all created with the VR template
    Any help is appreciated


    Click image for larger version

Name:	NoAmbientOcclusion.jpg
Views:	2
Size:	977.9 KB
ID:	1196398
    https://forums.unrealengine.com/atta...2&d=1475701639
    https://answers.unrealengine.com/que...ion-in-vr.html
    Last edited by Elias Leonard; 10-06-2016, 03:29 AM.

    #2
    Check the config files in the project folder, specifically defaultengine. I haven't looked at the most recent template but at one point it had r.ambientocclusionlevels = 0 in there for performance reasons. You are free to remove those overrides of course.
    Ryan Brucks
    Principal Technical Artist, Epic Games

    Comment


      #3
      No :/ I really recommend creating a VR template project in 4.13.1 and try to get the AO working.

      I think it's disabled somewhere in code or some blueprint maybe? But I can't find anything.

      Comment


        #4
        Its this line in defaultengine.ini

        r.DefaultFeature.AmbientOcclusion=False

        Set it to true. You can also try entering r.DefaultFeature.AmbientOcclusion 1 using the console.
        Ryan Brucks
        Principal Technical Artist, Epic Games

        Comment


          #5
          So I tried it and there is still no AO.

          (set the AO in the .ini to true and also checked for other possible options -> restarted the project)

          I tried to enter this line in the console and this is the result in the output log:
          Cmd: r.DefaultFeature.AmbientOcclusion 1
          r.DefaultFeature.AmbientOcclusion = "1"
          LogMaterial: Missing cached shader map for material DebugMeshMaterialFakeLight, compiling.


          Did it work with your VR template project? if so, are you using 4.13.1?
          Last edited by Elias Leonard; 10-06-2016, 05:21 AM.

          Comment


            #6
            Elias,

            Not sure if you resolved this problem, but I had to change additional values in the DefaultScalability.ini in your config folder
            The default scalable settings are stored for the Low, Medium, High, and Ultra Settings. There are groups of variables for each of the four settings in the file. The @0 settings are for Low, the @1 settings are for Medium, and so on.

            r.AmbientOcclusionLevels

            is set to 0. This defines how many mip levels your AO is using. Set it higher than 0 on the quality settings you are using on your project to get AO back in your project. Worked on my end.

            Comment


              #7
              Just as an FYI AO is EXTREMALLY expensive to render in VR and would most likely end up causing your VR project to run at a lower FPS. If you really need AO look into baking AO into your lightmaps using Lightmass. You can read more about Lightmass settnings from the following page.

              https://docs.unrealengine.com/latest...ows/Lightmass/

              Comment

              Working...
              X