Announcement

Collapse
No announcement yet.

Alpha Map Not Matching Assets UVs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    This screenshot shows the sub divided material in 3ds max to make the window planes black and the rest of the windows frame white, once this had been appliyed I would use the render to texture tool in 3ds max and then importate the texture into the unreal engine.

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	302.1 KB
ID:	1114357

    Thank you for your time
    - Adrian Seagrave

    Leave a comment:


  • replied
    Do you have an example of what you are trying to achieve? Are the maps lining up in your 3D modelling software? I'm just a little confused as to specifically what is not lining up.

    Leave a comment:


  • replied
    Originally posted by VaSSiLi View Post
    Double check to see if it is not a lighting artifact rather than a case of the UVs not matching the texture by viewing the scene in Unlit mode. (Alt+3 Keyboard shortcut). Your UV island padding also looks incredibly small in some places, which might be causing the issue. Whats the resolution of your texture?
    The texture is currently at 4096x4096 (It would most likely be down sampled later) but here is an additional image showing you the windows with the alpha map. I don’t believe it is the case of bleeding but rather the 2 maps not matching up with each other, but hope this helps.

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	650.9 KB
ID:	1114322

    Thank you for your time
    - Adrian Seagrave

    Leave a comment:


  • replied
    Double check to see if it is not a lighting artifact rather than a case of the UVs not matching the texture by viewing the scene in Unlit mode. (Alt+3 Keyboard shortcut). Your UV island padding also looks incredibly small in some places, which might be causing the issue. Whats the resolution of your texture?

    Leave a comment:


  • started a topic Alpha Map Not Matching Assets UVs

    Alpha Map Not Matching Assets UVs

    Hello all I made a post previously about my issue but it hadn't got much of a response so I thought ill remake a new thread to hopefully make my problem get understood better. Basically it seems that the alpha map is not matching my assets UV’s correctly, I haven’t got any idea why the material is behaving like this so I would be very grateful to anyone who can help.

    My alpha map is a template that has been created through 3Ds max’s render to texture so ideally it should match up to the UV’s for the asset in the unreal engine. The images below will show the assets alpha map as the diffuse just to point out how the white and black is not matching up and how it’s affecting the window frames. The other two additional images are showing other information such as the material set up for the asset and its UV’s.

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	684.2 KB
ID:	1192362

    Click image for larger version

Name:	Capture2.PNG
Views:	1
Size:	137.3 KB
ID:	1192363

    Click image for larger version

Name:	Capture3.PNG
Views:	1
Size:	387.3 KB
ID:	1192364

    Thank you for your time and if anyone needs anymore imformation ill repliy with it asap.
    - Adrian Seagrave
Working...
X