Announcement

Collapse
No announcement yet.

3D UMG Widget low quality / transparency issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    3D UMG Widget low quality / transparency issues

    Having some issues with 3D UMG widgets. This is the basics behind the system.

    So this is a mockup of what i'm trying to create:
    Click image for larger version

Name:	Goal.png
Views:	1
Size:	555.1 KB
ID:	1187929

    But I can't get the background image to be at 50% transparency despite using Appearance>Color and opacity. It's either 100% colored or 100% invisible. I've even tried importing the image with transparency applied in photoshop but i get the same result.
    Click image for larger version

Name:	Menu with bg a.png
Views:	1
Size:	156.8 KB
ID:	1187930

    I'm also having trouble with the rendering quality of opacity on some image assets such as my selection highlight. The asset should have a flowing transparency gradient but only displays up to a certain opacity.
    Click image for larger version

Name:	Menu select asset.png
Views:	1
Size:	26.4 KB
ID:	1187931
    Click image for larger version

Name:	menu no bg a.png
Views:	1
Size:	165.4 KB
ID:	1187932


    And finally i'm having some issues with overall quality, i'm often getting a jagged black border around multiple objects including images, buttons and text. All assets are clear in the widget editor but not when displayed in 3D space. You may also be able to notice it in other screenshots.
    Click image for larger version

Name:	border  jagged a.png
Views:	1
Size:	157.8 KB
ID:	1187933

    Any troubleshooting tips for these issues appreciated. ty.

    #2
    I have this exact problem, was a solution found?

    Comment


      #3
      So it turns out that by default blend mode is set to Masked on the 3D Widget in the World Outliner and setting it to Transparent fixes the problem.
      Click image for larger version

Name:	problem.PNG
Views:	1
Size:	44.1 KB
ID:	1115636

      Comment


        #4
        Thank you Tomster954! It was so confusing because it would blend masked by default so it appeared to have transparency working on some level, and I'd been spending tons of time messing with compression and import settings.

        Comment


          #5
          I have tried your method, it only works with HUD and not 3D widgets

          Tested on 4.22

          Comment


            #6
            Originally posted by ZMARDINI View Post
            I have tried your method, it only works with HUD and not 3D widgets

            Tested on 4.22
            It works, after setting it to transparent you have to click on Tint color and opacity and set A (Alpha) to a lower level

            Comment

            Working...
            X