Announcement

Collapse
No announcement yet.

Infinity Blade assets cause shaders to be recompiled constantly - why?!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I am not sure what the actual trees look like, but as always, composition and careful lighting can make even mediocre assets look amazing in a screenshot.

    Most likely the blackness is because you have too many unbuilt objects. Once you have more than a certain number of unbuilt objects the engine stops trying to make preview dynamic lighting for them.

    Leave a comment:


  • replied
    [MENTION=3692]RyanB[/MENTION]: Alright, that did the trick! Thanks a bunch.

    Anything I place into the scene becomes pitch black, even with SM5 preview mode, until I build lighting (and I don't have any dynamic lights in the scene). Perhaps that's expected?

    Also I get these kind of errors:

    Info SM_Plains_Castle_DemonDoor_01 Lightmap UV are overlapping by 49.9%. Please adjust content - Enable Error Coloring to visualize.
    Error SM_Plains_Castle_DemonDoor_01 Object has overlapping UVs.
    but the actor looks fine in PIE and in-game :/ Do I need to do anything about it ?

    And last question (hopefully ) - foliage looks odd :/ I don't have Apple device to check out actual game, but on screenshots trees in Infinity Blade definitely don't look like in UE4 :/ Is this how it should look like ?

    Click image for larger version

Name:	ue4_ib_foliage1.png
Views:	1
Size:	212.4 KB
ID:	1107883
    Full image: http://s32.postimg.org/hc5mz72v7/ue4_ib_foliage1.png

    Thanks
    Last edited by motorsep; 06-08-2016, 01:05 PM.

    Leave a comment:


  • replied
    Thanks, I will try doing that.

    Leave a comment:


  • replied
    You are probably building ddc for them one asset at a time. Not sure why they are black in Es2 preview mode but usually I solve the other issue by opening a content browser, unchecking "folders" view (so I can see all assets), then select ALL assets in the browser (ie click the first one, scroll to the end, hold 'shift' and click the last item) and then right click on any item to load everything. Brace yourself as it will probably take 30 minutes to an hour, but you can do this and grab a coffee and you should be able to avoid it happening every time.

    I would try to narrow down the ES2 thing in a new testmap, and also place some assets that you know work in the same scene. Then check usage flags for both, and make sure the IB assets get resaved after opening. It is possible that something isn't getting compiled and saved.

    Leave a comment:


  • replied
    I know I posted it not to long ago, but it's kinda critical :/

    Leave a comment:


  • Infinity Blade assets cause shaders to be recompiled constantly - why?!

    I began poking at Infinity Blade assets last night and it's impossible to work with them as every time I try drag'n'drop any static mesh from content browser into my scene, UE4 freezes (not quite, but can't really do much) and I get 100 something shaders recompiling. And it's like that for every single assets from Infinity Blade :/

    And on top of that, they appear pitch black in the viewport (and in PIE) when using ES2 preview mode. It's odd, since those assets are made for mobile platforms.

    How do I solve both issues ?

    Thanks
Working...
X