Announcement

Collapse
No announcement yet.

Meshes are lit with no lighting.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Meshes are lit with no lighting.

    Trying to prototype so geometry, and I've imported a few meshes in from Blender. I've UV wrapped the meshes, gave them two UVMaps, and made sure that the second map didn't have any overlapping UVs. I don't get any errors when building the lighting, and I set it to production lighting fore good measure, but my seen has 2 objects only. A static mesh, that I applied some started content material to, and a player start. There are no light sources, yet the meshes still show light and shadows. Whats the deal with that? Is there another setting for some generic directional or ambient lighting?

    #2
    Hi Gibdion,

    If you have set up a completely blank level with nothing other than the two objects you, when hit play you will see there are no lights. If you are just using the editor window and hit simulate you'll notice the object stay lit. This is a default light to allow you to work within your scene. You'll notice there are no shadows. If you add a point light you'll see the scene go dark with exception of where the light is reflecting off other objects.

    If this doesn't help can you post a screen shot of UE4 with the scene outliner in the window so I can see if there are any tips or pointers I can offer?

    Thank you!

    Tim
    Tim Hobson | Learning Resources | Epic Games
    UE4 Documentation

    Comment


      #3
      Its the same view from both Simulate and Play. I was able to recreate the effect following the same procedures in a new project. I know the lighting adjusts itself but this is extremely bright. Could converting a project from 4.1 to 4.2 affect this because that was what was done in this instance.

      Click image for larger version

Name:	light.jpg
Views:	1
Size:	208.9 KB
ID:	1052044

      Comment


        #4
        Hi Gibdion,

        I'm not sure about the conversion. There is always that possibility.

        From what I'm seeing this is not anything out of the ordinary aside from you saying it was doing this in "Play" mode.

        Can you add a light to the level, Build lighting, delete the light after lighting build is completed, build lighting, then play in the editor. This should get rid of the default lighting.

        The blank level in a new scene has a default light, or unlit status until a light is added so that you can see your meshes otherwise you'd be working the dark.

        Thanks!

        Tim
        Tim Hobson | Learning Resources | Epic Games
        UE4 Documentation

        Comment


          #5
          Originally posted by Gibdion View Post
          Its the same view from both Simulate and Play. I was able to recreate the effect following the same procedures in a new project. I know the lighting adjusts itself but this is extremely bright. Could converting a project from 4.1 to 4.2 affect this because that was what was done in this instance.

          [ATTACH=CONFIG]5404[/ATTACH]
          Hm, are you doing it in just created "Empty level"?
          I have exactly same problem when I put first mesh into "Empty level".
          Try to change View Mode to unlit and then back to lit
          SuperGrid: Marketplace Page | Feedback Thread | Demo | Website
          Level design and prototyping for newbies

          Comment


            #6
            The 'lighting' in the above image is more uniform because between the reply of this post I deleted everything and recreated, but as far as the tips, yes the light is still there when removing lights. That is actually what got me noticing the default lighting. As I was moving around the mesh, I noticed a white light come from somewhere, and my light was blue, so when I removed my blue light and rebuilt the map, I had a horrible light by some pale white light. I delete it all, and even reimported my meshes, and got the above image with a more unified lighting. The attached image I guess is working fine. If I run into the issue again, I'll post a picture first prior to trying to "fix" it myself.

            Yes, I'm doing this from an 'empty level' but changing the view doesn't alter the lighting.

            Comment


              #7
              I post earlier but becouse of the forums problems it was deleted
              I said that I had the same problem, and i attach a gif to illustrate.

              https://www.dropbox.com/s/xqs89klas2vib3q/light.gif
              (download the gif)

              thanks!
              pd: Excuse my English.

              Comment


                #8
                Might be worth checking - under your "World Settings" there's "Environment Intensity" which is essentially an ambient light with some occlusion. Make sure that's set to 0. Other than that.......I have no ideas.
                Chris Horne
                #unrealengine: VerseVR|Chris
                www.versevr.com
                www.twitter.com/distastee

                Comment


                  #9
                  Thanks for that tip. I didn't know of that setting.

                  Comment


                    #10
                    Originally posted by Gibdion View Post
                    Thanks for that tip. I didn't know of that setting.
                    No problem. I slammed my head against my monitor for a decent while (maybe a day?) before I realized the environment ambient was being turned on at map creation.
                    Chris Horne
                    #unrealengine: VerseVR|Chris
                    www.versevr.com
                    www.twitter.com/distastee

                    Comment


                      #11
                      Yap, thank you. Had the same issue.

                      Comment


                        #12
                        Originally posted by opticol View Post
                        Might be worth checking - under your "World Settings" there's "Environment Intensity" which is essentially an ambient light with some occlusion. Make sure that's set to 0. Other than that.......I have no ideas.
                        4 years later... thank you so much! finally problem solved

                        Comment


                          #13
                          If the problem persists, make sure you delete the "Map Build Data", and "Build" lighting again. I've found this bug whenever I duplicate my project, and the lighting refuses to update even after I build it again. Deleting the file and creating it again seems to work.

                          Comment

                          Working...
                          X