Announcement

Collapse
No announcement yet.

How to disable depth test for 3D UMG widget ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to disable depth test for 3D UMG widget ?

    Is it possible to disable depth test on 3D UMG widget ? (so that it renders over any geometry in the scene)

    Thanks

    #2
    I am also looking for this!! *grumble grumble grumble* lol.
    Outer Planet Studios
    http://outerplanet.webflow.io/

    Comment


      #3
      There is some good stuff in the reply I got here: https://www.reddit.com/r/unrealengin...epth_pass_how/

      Unfortunately none would work for mobile VR and 3D widget (UMG)

      Epic, please help mobile VR devs

      Comment


        #4
        So, if it's not feasible to achieve with current UE4, please let us know and it would be filed as feature request

        Comment


          #5
          Bumpy bump

          Comment


            #6
            Look for Material'/Engine/EngineMaterials/Widget3DPassThrough.Widget3DPassThrough' material in the engine content folder (make sure the content is visible by going to the view options on the bottom right corner of the content browser) Open up the material and turn on disable depth test, save and you are done.

            Note: It will make all 3D widgets have depth test disabled from now on.
            Bacon Man : An Adventure (UE4)

            Comment


              #7
              Originally posted by TheAgent View Post
              Note: It will make all 3D widgets have depth test disabled from now on.
              Thanks, but I only need to disable depth testing on a few 3D widgets that are used as 3D gui elements (in VR, mobile). Is it not possible?

              Comment


                #8
                Widgets in the world act different to ones attached to camera. Those will act normal, only those attached to camera, like a HUD will have Depth Disabled. And dont forget in Widget attached to camera to set depth etc. 0 far 100+ closer...

                EDIT:

                For HUD Widgets - Set to Translucent and check Render Custom Depth Pass and Set your Translucency Sort Priority (again ) far away 100+ higher is closer..

                For World Widgets - Set to Masked and check Render Custom Depth Pass (no need to set Translucency Sort Priority - 0 is fine)

                This should help...

                UI-UMG in World will now fall behind objects etc.
                And your HUD will be depth disabled - and over everything...
                Last edited by WilliamHooper; 06-02-2016, 11:17 PM. Reason: extra info

                Comment


                  #9
                  Hi. I'm aware this thread is a few years old, but I'm hoping some of you might have an answer.

                  ​​​​​When disabling depth test, how can I get the line trace to hit only those objects? My menu system is depending on the line tracer, but when the menu is spawning inside a wall, the tracer still stops at the wall or floor etc. I'd appreciate any hints here. Thank you.

                  Comment


                    #10
                    Hello, WilliamHooper, I can't get the following to work:

                    "For World Widgets - Set to Masked and check Render Custom Depth Pass (no need to set Translucency Sort Priority - 0 is fine)"

                    I have a camera in a blueprint (motionControllerPawn), and I created a widget as a child of that camera, then set "details>rendering>renderCustomDepthPass". however, the widget is still occluded by scenery, etc.

                    Can you offer any suggestions?


                    Comment

                    Working...
                    X