Announcement

Collapse
No announcement yet.

Problem with lighting / Maps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with lighting / Maps

    Hey guys,
    I'm just playing a bit arround with the lighting and some assest and i found this weird issue, after building the light, the main shadow on the ground is missing "from the whole object" any ideas why?
    I also have a second problem with the light maps i guess, after some meters distance the lightmap changes "or whatever" and i become this lighting issues "market in the red area on the picture". When coming near to the object, the lighting issue just
    disapperas and the asset looks correct.... ???

    The asset "the red market part" has a light map resolution of 1024.


    #2
    Is the UV map for that asset set up correctly? (no overlapping UV's). Are you sure there's no doubling of geometry, or flipped normals or anything weird like that going on with your model? Those are the things' I'd check if I was troubleshooting it.
    Trevor Lee

    Comment


      #3
      Yes the UV Map is set up correctly, no overlapping etc... the geometry on this parts is really simple, it has about 200 triangles or something and there is also no doubling geometry or flipped normals. The same thing happens without a normal attched to the object...

      The funny thing is when i stay directly next to this part, the light map looks correctly, this issue appears only in the distance...

      Comment


        #4
        Have you already increased the lightmap resolution + added a lightmass importance volume

        Comment


          #5
          Yes, the lightmass importance volume is in the scene.... the lightmap resolution of every part is 1024 which is even to big and takes me like 70 min to build it up for this 15 objects...
          what about the shadow on the ground? why they disappear after building the light ?

          The picture below shows my issue, the lighting issue dissaperas when i move closer to the object.... "right picture"

          Last edited by A-J-K; 06-08-2014, 03:20 PM.

          Comment


            #6
            Originally posted by Adik View Post
            what about the shadow on the ground? why they disappear after building the light ?
            Increase the lightmap resolution of the ground

            Comment


              #7
              ouh jesus ok.... i even didn't know that the ground has a seperate lightmap resolution but where the heck i can found it.. ?

              Comment


                #8
                Originally posted by Adik View Post
                ouh jesus ok.... i even didn't know that the ground has a seperate lightmap resolution but where the heck i can found it.. ?
                It depends which type of ground you are using ^^

                landscape -> in the properties tab on the right side of the window
                mesh -> in the static mesh editor

                Comment


                  #9
                  I'm using currently the landscape, i know that there are options on the right site but which one is for the lightmap resolution and what is a good value for it ?

                  Comment


                    #10
                    Click image for larger version

Name:	res_landscape.jpg
Views:	1
Size:	63.3 KB
ID:	1051157

                    I personally wouldn't go above 10 -> so stay as low as possible!!

                    Comment


                      #11
                      perfect thanx!
                      Hopefully someone has a resolution for my second problem too....

                      Comment


                        #12
                        For some reason i still get a weird shadow result.... ???

                        Comment


                          #13
                          No one here with an idea what im doing wrong ?

                          Comment


                            #14
                            Set your view mode to light map density using the perspective viewport drop down options. That should show you the size of your light map texels. My guess is they are still rather large compared to those thin beams.
                            Ryan Brucks
                            Principal Technical Artist, Epic Games

                            Comment


                              #15
                              After setting the viewport to light map density it looks lime this... but i have still no idea where the issue is and what the light map densitiy should tell me ?

                              Comment

                              Working...
                              X