Announcement

Collapse
No announcement yet.

More Detailed Dynamic Shadows?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    More Detailed Dynamic Shadows?

    Hello,

    I am using a Dynamic LightSource for the Light in my Scene and have got a lot of troubles getting them to look good. I have tried every thing you could do under the "Cascaded Shadow Maps" options but It only looks the way I want if you stand directly on the Shadow of for example a Tree. And if you are standing at the start of the Shadow the first Half looks like it should be but then the second half is apperently in the next Cascaded Level or Whatever it is called and it just looks wrong. Is there any way to strech the distance of those different Levels so for example 1000 Units around the Player is the best Detail mode and then the other Cascade Levels are starting. I haven't seen any options for that anywhere and I tried everything I could think of.
    There is a "Dynamic shadow quality improvements" Point in the Roadmap set to be done in June/July but I don't know if that will add these options to it or just do other improvements, since that Point isn't very specific about what It will improve.
    So do I have to wait for that next Update or is there any way to fix the Shadow Quality now?

    #2
    Originally posted by Nobody View Post
    Hello,

    I am using a Dynamic LightSource for the Light in my Scene and have got a lot of troubles getting them to look good. I have tried every thing you could do under the "Cascaded Shadow Maps" options but It only looks the way I want if you stand directly on the Shadow of for example a Tree. And if you are standing at the start of the Shadow the first Half looks like it should be but then the second half is apperently in the next Cascaded Level or Whatever it is called and it just looks wrong. Is there any way to strech the distance of those different Levels so for example 1000 Units around the Player is the best Detail mode and then the other Cascade Levels are starting. I haven't seen any options for that anywhere and I tried everything I could think of.
    There is a "Dynamic shadow quality improvements" Point in the Roadmap set to be done in June/July but I don't know if that will add these options to it or just do other improvements, since that Point isn't very specific about what It will improve.
    So do I have to wait for that next Update or is there any way to fix the Shadow Quality now?
    There's plenty of ways today to get shadow maps to look better, I'd just wait and not worry so much about it.

    Comment


      #3
      What settings are you using now? I've been able to get my shadows looking decent. Got and screenshots of what's going on/your settings?
      Trevor Lee

      Comment


        #4
        Originally posted by Hyperloop View Post
        What settings are you using now? I've been able to get my shadows looking decent. Got and screenshots of what's going on/your settings?
        My Cascade Settings are like this:
        Click image for larger version

Name:	iKLdtFr.jpg
Views:	1
Size:	19.4 KB
ID:	1051145

        And I have tried nearly ever combination and also the other settings in the light but nothing worked so far.

        My Problem is like this. If I stand like 2 meters in front of the Shadow it looks like this:

        Click image for larger version

Name:	VPh66fV.jpg
Views:	1
Size:	132.8 KB
ID:	1051146

        And If I stand directly on it it looks like it should be:

        Click image for larger version

Name:	G0QkqGQ.jpg
Views:	1
Size:	174.0 KB
ID:	1051147

        I would like to have that detail of the shadow in an area of like 5m or so around me. Otherwise it just looks so cheap.

        Comment


          #5
          Does it looks the same when you run it as a standalone game ? You can try changing the quality setting for the editor, I find that even with editor shadows on a high setting the shadows will still look crisper when running standalone.

          Comment


            #6
            Originally posted by MrNexy View Post
            Does it looks the same when you run it as a standalone game ? You can try changing the quality setting for the editor, I find that even with editor shadows on a high setting the shadows will still look crisper when running standalone.
            Yeah looks exactly the same when running standalone and the quality settings are maxed.

            Comment


              #7
              I'm not in front of the engine right now, but it looks like your transition fraction is set way too low as well as the shadow distance fadeout fraction.
              Trevor Lee

              Comment


                #8
                Originally posted by Hyperloop View Post
                I'm not in front of the engine right now, but it looks like your transition fraction is set way too low as well as the shadow distance fadeout fraction.
                Changing the Values just make it look worse. "Shadow distance fadeout fraction" just makes a difference from a far to fade shadows away and is not relevant for stuff near you. And "Transition fraction" of 10% is okay and can only go up to 0.3 = 30%, so thats not the problem. The Problem is that that transition happens at a distance I am not able to control or change.

                Comment


                  #9
                  Go to:
                  <Engine Version>\Engine\Config

                  And find ConsoleVariables.ini

                  Add this line:

                  r.Shadow.CSM.MaxCascades=10

                  It will make possible for shadows to use more than 3 (or 4) cascades. The more cascades you are using the more heavy shadow rendering is.

                  Other that than you can tweak some non directly exposed shadow paramters directly in editr using command line cvars that start from r.shadow.*

                  You will also need, to tweak your shadow setting in directional light. I can't you give any settings, because it really dependent on level and what are you trying to achieve.

                  Beyond that Shadow Maps technique are really bad at rendering detailed shadows to begin with. There are always will be trade offs that will depend on myriads of interconnected parameters. Best thing you can do is to tweak these parameters and hope for the best.
                  https://github.com/iniside/ActionRPGGame - Action RPG Starter kit. Work in Progress. You can use it in whatever way you wish.

                  Comment


                    #10
                    Originally posted by MrNexy View Post
                    Does it looks the same when you run it as a standalone game ? You can try changing the quality setting for the editor, I find that even with editor shadows on a high setting the shadows will still look crisper when running standalone.
                    Scalability settings don't affect the packaged game. They're just for the editor preview.

                    Comment

                    Working...
                    X