Announcement

Collapse
No announcement yet.

Running in Standalone mode is much slower than Separate Window...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Running in Standalone mode is much slower than Separate Window...

    I'm using version 4.2 and I just wonder if anyone else has this same problem.

    I've done some searches about it and it seems like there used to be a problem with this before 4.1. I only really started my project in version 4.1 and also updated to 4.1.1 and never had this happen but now in version 4.2 I get much lower frame rates when I run in Standalone mode. When I simply run in a Separate Window there are no problems, I get smooth frame rates.

    I've been trying to find a reason for it, like disabling things and testing it like that but it just always is much slower. It seems like it's just generally slower regardless of what's on screen or what features are enabled or disabled.

    So, I just wanted to feel out the forums first and see if people have similar problems and maybe if there's a known solution or something before maybe reporting as an actual problem.
    Ninja Arcade - UE4 - Forum Thread -- Ninja Arcade - UE4 - Demo v0.02a

    #2
    Hi Obihb,

    Sorry to hear about the low fps with this. Would you mind posting this on the AnswerHub in the 'Bugs' section for quicker assistance and tracking purposes? I'll start looking into this as well.

    Thank you!

    Tim
    Tim Hobson | Learning Resources | Epic Games
    UE4 Documentation

    Comment


      #3
      Hi Obihb,

      Here are the stats I got from the using 4.1.1 vs 4.2

      Tested on:

      Shooter Game
      4.1.1
      Standalone Game: ~42fps
      New Editor Window: ~30fps

      4.2
      Standalone Game: ~39fps
      New Editor Window: ~40fps

      Cave Effects
      4.1.1
      Standalone Game: ~49fps (this was in the heavy snow area outside of the cave. This was the lowest FPS I could get. Most everything stayed around 55-60fps)
      New Editor Window: ~27fps

      4.2
      Standalone Game: ~36fps (I did see a drop here though)
      New Editor Window: ~54fps


      Are you using an example from the marketplace when doing this a custom project? Anything that helps me replicate it on my end would be beneficial.

      Also, could you list your system specs as well?

      Thank you!

      Tim
      Tim Hobson | Learning Resources | Epic Games
      UE4 Documentation

      Comment


        #4
        Thank you Tim for the reply.

        I am using a custom project. I did try and test the Shooter but it did not run in 4.2. It wants to compile something. I tested it in 4.1.1 and it runs fine. Although my own project ran fine in 4.1.1 also. I will test more on my side with a brand new project and see what happens.

        So you can see also in your test a massive frame rate drop in Standalone mode.

        In fact, I see your 4.1.1 results seems like mine as well, I used to get better FPS in Standalone mode when I was using 4.1.1. Now it's kinda like it's swapped.

        My system is..

        Core i7 3770k
        16GB mem
        Geforce 680 GTX (driver v337.88)
        Win 8.1 64bit (fully updated)
        Last edited by Obihb; 06-06-2014, 12:07 PM.
        Ninja Arcade - UE4 - Forum Thread -- Ninja Arcade - UE4 - Demo v0.02a

        Comment


          #5
          Hi Obihb,

          Are you using C++ and Visual studio to compile your projects?

          Also a note about the Shooter Game in 4.2. Since it's based in code you will need to recompile it using Visual studio 2013. However, if you download Shooter Game from the Marketplace while set to 4.2 it will download and run fine. This will not overwrite your 4.1 or earlier version of the project.

          While I will agree that I did see a drop in frame rate I wouldn't say that my drop of ~3 FPS for Shooter Game was a "Massive" drop. The drop in Cave effects was more significant but without further testing I couldn't say for sure.

          The true to way to test though would be to use Frontend and bake the game. Having the game running with the editor still open in the back ground is going to affect the FPS. You can test this yourself by opening up Cave Effects. Before/or after the Standalone Game Window is opened you need to turn off the "Realtime" check box in the viewport. Once turning that off you will see that the FPS increases (~54 FPS).

          Depending on what's happening in your project viewport and trying to run the game can have effects on your project's FPS.

          Thank you!

          Tim
          Tim Hobson | Learning Resources | Epic Games
          UE4 Documentation

          Comment


            #6
            So I tested 2 clean 3rd Person template projects. The easiest way I can get the frame rate drop to happen is to simply push up resolution. With 1680x1050 I already get below 60fps unless I'm staring directly at a wall then it's just barely above 60. I also tested another one by putting some objects and more complex materials. Threw in a bunch of those chairs and applied some brick and wood materials from the demo content. And that would make it drop even lower, around 50, and in some cases depending on the view even below 50.

            When I run in the separate window, it sits at around 90fps with the clean scene and around 85 with the scene that I added the stuff into.

            I don't know if this helps, but as far as I can tell, it just always is slower no matter what I run or what project I run. I tested 3 separate projects. Two being the 3rd Person template and one my own custom project that was originally derived from the 3rd person template.
            Ninja Arcade - UE4 - Forum Thread -- Ninja Arcade - UE4 - Demo v0.02a

            Comment


              #7
              Thanks for your reply again, I appreciate the time you spend on this.

              I am not using C++. I just haven't been able to download the shooter game again to test it out. I will download the 4.2 to test it though, compared to 4.1.1.

              I just want to mention that I do keep real time render off basically at all times when I work and I did make sure originally before I posted anything, that it wasn't the problem, and it's not.

              The reason I posted about this in the first place is simply because going from version 4.1.1 to version 4.2, there is a really big difference in the frame rates I get under the same conditions.
              Last edited by Obihb; 06-06-2014, 01:15 PM.
              Ninja Arcade - UE4 - Forum Thread -- Ninja Arcade - UE4 - Demo v0.02a

              Comment


                #8
                I'm having the same problem as OP and looking at this thread on the Answers hub it seems 'Play In Standalone Game' mode doesn't pick up the Engine Scalability settings set in the editor. This appears to be true as bumping the scalability to 'Epic' in my editor produces a similar FPS to that of standalone.

                While the final game will obviously expose video settings through a menu, what is the best practice for controlling graphics quality in the standalone mode? Should I just hardcode some ini files for now or rig something up through blueprint like the person in the Answers thread has done?

                Steam Early Access: Drunk On Nectar - The Nature Simulator

                UE4 Plugins: DoN’s Dynamic Mesh FX | DoN’s 3D Pathfinding

                Comment


                  #9
                  I was having the same performance problem until I turned off real-time mode before entering "Play In Standalone Game". After I did that, I got a constant 62 FPS. I don't know if anyone suggusted it yet, but you might want to try this out.

                  Comment


                    #10
                    Originally posted by KoldKam View Post
                    I was having the same performance problem until I turned off real-time mode before entering "Play In Standalone Game". After I did that, I got a constant 62 FPS. I don't know if anyone suggusted it yet, but you might want to try this out.
                    Hmmm no luck there - the standalone mode seems to be picking the settings from elsewhere. Eg: In my editor screen space realtime reflections are OFF as my settings are 'medium', in standalone mode SSRR is ON. It's not that big a deal as I'm sure I can configure the settings somewhere but I was curious as to what the best practice is for this.

                    Steam Early Access: Drunk On Nectar - The Nature Simulator

                    UE4 Plugins: DoN’s Dynamic Mesh FX | DoN’s 3D Pathfinding

                    Comment


                      #11
                      Originally posted by KoldKam View Post
                      I was having the same performance problem until I turned off real-time mode before entering "Play In Standalone Game". After I did that, I got a constant 62 FPS. I don't know if anyone suggusted it yet, but you might want to try this out.
                      where do you turn off this real time mode? I have seek in editor and project preferences but didn't find it

                      Comment


                        #12
                        Originally posted by wARmAcH1n3 View Post
                        where do you turn off this real time mode? I have seek in editor and project preferences but didn't find it
                        Use the hotkey Ctrl-R or click on the button in the top-left corner of your viewport (the dropdown like thingee)

                        Steam Early Access: Drunk On Nectar - The Nature Simulator

                        UE4 Plugins: DoN’s Dynamic Mesh FX | DoN’s 3D Pathfinding

                        Comment


                          #13
                          I've been working with the ShooterGame4.1 for about 2 months now. Decided to update to 4.3 today, downloaded ShooterGame4.3 and I noticed my StandAlone game my fps was horrendous, around 5-10fps, where as my PIE fps is about 55-60fps. Ctrl-R worked and restored my StandAlone FPS to 55-60fps. Really odd, what is causing this?

                          Comment


                            #14
                            Originally posted by Mentos View Post
                            I've been working with the ShooterGame4.1 for about 2 months now. Decided to update to 4.3 today, downloaded ShooterGame4.3 and I noticed my StandAlone game my fps was horrendous, around 5-10fps, where as my PIE fps is about 55-60fps. Ctrl-R worked and restored my StandAlone FPS to 55-60fps. Really odd, what is causing this?
                            AFAIK, running PIE with the editor on real-time in the background is essentially running two instances of your game simultaneously - even while your editor is in the background it continues to compute. Ctrl-R renders the editor static freeing your system to be used by the PIE session.

                            Personally I leave real-time off as I've noticed both GPU temperatures and power consumption remain high even if I have the Unreal Editor minimized - which is pretty much all the time I'm going through tutorials/resources/etc

                            Steam Early Access: Drunk On Nectar - The Nature Simulator

                            UE4 Plugins: DoN’s Dynamic Mesh FX | DoN’s 3D Pathfinding

                            Comment


                              #15
                              Originally posted by VSZ View Post
                              AFAIK, running PIE with the editor on real-time in the background is essentially running two instances of your game simultaneously - even while your editor is in the background it continues to compute. Ctrl-R renders the editor static freeing your system to be used by the PIE session.

                              Personally I leave real-time off as I've noticed both GPU temperatures and power consumption remain high even if I have the Unreal Editor minimized - which is pretty much all the time I'm going through tutorials/resources/etc
                              Well it is odd that I never experienced this in 4.1

                              Comment

                              Working...
                              X