Announcement

Collapse
No announcement yet.

Disable DFAO on certain meshes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Any updates on this?
    I have a large custom mesh im using as terrain and cannot seem to deactivate the DFAO for a single mesh.
    Unreal 4.24.3
    On the asset I have set Distance Fields Resolution Scale to 0 and have tried using 1m cube as the "replacement mesh".
    Have also unchecked on the Actor, "Distance Field Indirect Shadow" and "Affect Distance Field Lighting".
    Yet I am still getting pretty bad blobby shadowing in the DFAO on this mesh.

    As a workaround, is there a way to make the skylight not affect certain objects? Because these DFAO shadows are coming from the Movable SkyLight, could i use one Skylight for some assets, and a different skylight for other assets?


    Leave a comment:


  • replied
    I cant find a report of this bug in the Unreal Issues Database so I will create a new one.

    Leave a comment:


  • replied
    Originally posted by rosegoldslugs View Post

    If you need the distance fields of the mesh for whatever reason, you can just toggle "Affects Distance Field..." per instance, in the foliage tool, or the grass actor. Otherwise, you can disable it completely by setting the Distance Field Resolution in for the Static Mesh to 0, then "Apply Changes." Not sure what version was being used back in the original 2016 posts, but I haven't had any issues with disabling DFs this way in a long time.
    Thank you, but this is the grass tool, not the foliage tool.
    I think the 2016 issue still remains in 4.22. Even if you set those settings on the mesh actor, the DFAO still shows for the scattered grass objects.

    Leave a comment:


  • replied
    Originally posted by 2car View Post
    Sorry for resurrecting an old thread.

    We need to disable DFAO on our grass as it makes the 3D grass not blend well with the underlying grass material.
    Is there a way to do this?
    If you need the distance fields of the mesh for whatever reason, you can just toggle "Affects Distance Field..." per instance, in the foliage tool, or the grass actor. Otherwise, you can disable it completely by setting the Distance Field Resolution in for the Static Mesh to 0, then "Apply Changes." Not sure what version was being used back in the original 2016 posts, but I haven't had any issues with disabling DFs this way in a long time.

    Leave a comment:


  • replied
    Sorry for resurrecting an old thread.

    We need to disable DFAO on our grass as it makes the 3D grass not blend well with the underlying grass material.
    Is there a way to do this?

    Leave a comment:


  • replied
    I have the same problem. Tried disabling shadows, using a super small replacement mesh and nothing helps. Has anyone found a solution yet?

    Leave a comment:


  • replied
    That is so odd. I do what you need out of the shadows in my game and those meshes are not affected in any way by DFAO. So at this point, something else is wrong.

    Leave a comment:


  • replied
    As you see cast shadows is already off, but this doesn't affect the DFAO.
    Scale at 0 doesn't rebuild my mesh distance field, why?

    Leave a comment:


  • replied
    The problem is the solution is to set Distance Field scale to 0. The shadows you're seeing is most likely Cascade using inset shadows. You can also disable shadows directly from the mesh view. Open it up, see where the materials are listed and uncheck "Cast shadow"

    Leave a comment:


  • replied
    hacky workaround could be to use a mesh so small as the df replacement mesh that it won't have any real influence on the AO. haven't tried this though, so just guessing here.

    Leave a comment:


  • started a topic Disable DFAO on certain meshes

    Disable DFAO on certain meshes

    Hello,
    Is it possible to disable DFAO on certain meshes?
    I am spawning grass with grass tool, and this is the result with DFAO enabled:

    Click image for larger version

Name:	DFAO_ON.JPG
Views:	1
Size:	239.3 KB
ID:	1172315


    this is the result with DFAO disabled in the game:

    Click image for larger version

Name:	DFAO_OFF.JPG
Views:	1
Size:	240.4 KB
ID:	1172316

    I tried to set distance field scale to 0 on the mesh but it doesn't work, either cast shadows off will fix it.


    Is there a way to disable DFAO on a mesh withouth disabling it in the project?

    Thank you
Working...
X