Announcement

Collapse
No announcement yet.

Black shadows along landscape seems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    wow, I didn't expect you to do the effort of making a video about it. Thanks man.

    While this is a viable solution if I just wanted to "merge" two terrains together, I think it is not an entirely viable solution if you have a tiled terrain that you want to import from World Machine.

    But thanks it gives me a possible solution.

    I will keep investigating and if worse comes to worse I will have to offset my terrains to overlap like yours and do the manual fixup.

    If I ever find a solution I will make sure to post it here.

    Leave a comment:


  • replied
    Here we go:



    Thats how I would do it (of course you will have to do it much more precise )

    Leave a comment:


  • replied
    I will record you a video -> but of course you will see something like a seam, but you can hide it with meshes

    Leave a comment:


  • replied
    I'm sorry I tried to do what you said here but like that the terrain vertices don't match/coincide anymore at all.
    If I just smooth one side of the terrain (even if I make them overlap - which sounds like a strange idea) then if I look at the terrain from the opposite side of the seam I see a gap between the two terrains - surely that can't be right. I am probably not doing exactly what you are doing. Could you describe a bit in more detail what you did ?

    Leave a comment:


  • replied
    Originally posted by Chrys View Post
    how did you modify both terrains with the smooth tool and guarantee that they share the same vertex height for each vertex along the seam ?

    when I try use the smooth tool it only modifies the "current" terrain.
    I just increased one landscape at the seam and then I smoothed the part that is overlapping:

    Click image for larger version

Name:	smooth.jpg
Views:	1
Size:	17.2 KB
ID:	1052585

    Smooth the part where the arrow is pointing at

    Leave a comment:


  • replied
    Originally posted by Jacky View Post
    Have you tried placing those landscapes with World Browser and see how lighting builds like that?
    yes Jacky, I used to place them with world browser in 4.2 and with world composition minimap in 4.3

    Leave a comment:


  • replied
    how did you modify both terrains with the smooth tool and guarantee that they share the same vertex height for each vertex along the seam ?

    when I try use the smooth tool it only modifies the "current" terrain.

    Leave a comment:


  • replied
    Have you tried placing those landscapes with World Browser and see how lighting builds like that?

    Leave a comment:


  • replied
    Actually the standard resolution ^^ (1.0)

    Edit:

    Yep, you already saw it

    Leave a comment:


  • replied
    Oh oh that would be a problem though because my terrains are created in Wold machine.
    That would mean I need to go through all my terrains and manually fix them... ouch!

    What lighting resolution did you use?

    Ps:nvm just saw its 1.0

    Leave a comment:


  • replied
    As far as I can see you just have to work more carefully Those shadows will appear when some of the landscape parts aren't connected very well:

    Click image for larger version

Name:	landscape_light.jpg
Views:	1
Size:	377.7 KB
ID:	1052584

    The red part was overworked by me and as you can see, no wrong shadows are there.

    How I did it:
    1. First of all import your landscapes
    2. make sure that the part, where the landscapes are connected, is overlapping a little bit
    3. now decrease (erosion tool), increase or smooth the overlapping seams so that they are connected very well

    Leave a comment:


  • replied
    Ok, I will take a look at it

    Leave a comment:


  • replied
    I sent you a private message with a simple test project.

    Leave a comment:


  • replied
    Is it possible for you to upload the map somewhere so that we can take a look at it/try some stuff ?

    Leave a comment:


  • replied
    Anyone knows how I can fix this? I tried again in the 4.3 preview and I still get these weird artefact shadows along the seems of my terrains

    Leave a comment:

Working...
X